Opened 5 months ago

Closed 5 months ago

#3072 closed help (answered)

Cray Fortran Compile Error

Reported by: mtodt Owned by: um_support
Component: UM Model Keywords: N96 fcm_make
Cc: Platform: ARCHER
UM Version: 10.6

Description

Hi

I'm trying to run u-bo395, an N96 UMv10.6 suite, on ARCHER but fcm_make2_um fails with the following error message:

[FAIL] ftn -oo/diagnostics_adv_mod.o -c -I./include -s default64 -e m -J ./include -I/work/y07/y07/umshared/gcom/cce8.4.1/gcom6.1/archer_xc30_cce_mpp/build/include -O2 -Ovector1 -hfp0 -hflex_mp=strict -h omp /work/n02/n02/mtodt/cylc-run/u-bo395/share/fcm_make_um/preprocess-atmos/src/um/src/atmosphere/dynamics_advection/diagnostics_adv.F90 # rc=1
[FAIL] 
[FAIL] 
[FAIL] ftn-855 crayftn: ERROR DIAGNOSTICS_ADV_MOD, File = ../../../../../fs2/n02/n02/mtodt/cylc-run/u-bo395/share/fcm_make_um/preprocess-atmos/src/um/src/atmosphere/dynamics_advection/diagnostics_adv.F90, Line = 11, Column = 8 
[FAIL]   The compiler has detected errors in module "DIAGNOSTICS_ADV_MOD".  No module information file will be created for this module.
[FAIL] 
[FAIL] 
[FAIL] ftn-292 crayftn: ERROR DIAGNOSTICS_ADV, File = ../../../../../fs2/n02/n02/mtodt/cylc-run/u-bo395/share/fcm_make_um/preprocess-atmos/src/um/src/atmosphere/dynamics_advection/diagnostics_adv.F90, Line = 41, Column = 5 
[FAIL]   "AC_DIAGNOSTICS_MOD" is specified as the module name on a USE statement, but the compiler cannot find it.
[FAIL] 
[FAIL] 
[FAIL] ftn-113 crayftn: ERROR DIAGNOSTICS_ADV, File = ../../../../../fs2/n02/n02/mtodt/cylc-run/u-bo395/share/fcm_make_um/preprocess-atmos/src/um/src/atmosphere/dynamics_advection/diagnostics_adv.F90, Line = 468, Column = 23 
[FAIL]   IMPLICIT NONE is specified in the local scope, therefore an explicit type must be specified for data object "QCL_ADV".
[FAIL] 
[FAIL] 
[FAIL] ftn-428 crayftn: ERROR DIAGNOSTICS_ADV, File = ../../../../../fs2/n02/n02/mtodt/cylc-run/u-bo395/share/fcm_make_um/preprocess-atmos/src/um/src/atmosphere/dynamics_advection/diagnostics_adv.F90, Line = 469, Column = 16 
[FAIL]   An allocate object must be either a pointer or an allocatable array in an ALLOCATE statement.
[FAIL] 
[FAIL] 
[FAIL] ftn-724 crayftn: ERROR DIAGNOSTICS_ADV, File = ../../../../../fs2/n02/n02/mtodt/cylc-run/u-bo395/share/fcm_make_um/preprocess-atmos/src/um/src/atmosphere/dynamics_advection/diagnostics_adv.F90, Line = 488, Column = 16 
[FAIL]   Unknown statement.  Expected assignment statement but found "(" instead of "=" or "=>".
[FAIL] 
[FAIL] Cray Fortran : Version 8.5.8 (20170217211354_0071b093c0867e302a5c08403fe34f8aa78fc212)
[FAIL] Cray Fortran : Fri Nov 08, 2019  15:26:09
[FAIL] Cray Fortran : Compile time:  0.2360 seconds
[FAIL] Cray Fortran : 1101 source lines
[FAIL] Cray Fortran : 5 errors, 0 warnings, 0 other messages, 0 ansi
[FAIL] Cray Fortran : "explain ftn-message number" gives more information about each message.
[FAIL] compile    0.6 ! diagnostics_adv_mod.o <- um/src/atmosphere/dynamics_advection/diagnostics_adv.F90
...
[FAIL] ! AC_CTL_MOD.mod      : depends on failed target: ac_ctl_mod.o
[FAIL] ! DIAGNOSTICS_ADV_MOD.mod: depends on failed target: diagnostics_adv_mod.o
[FAIL] ! DIAGNOSTICS_LSRAIN_MOD.mod: depends on failed target: diagnostics_lsrain_mod.o
[FAIL] ! ac_ctl_mod.o        : update task failed
[FAIL] ! diagnostics_adv_mod.o: update task failed
[FAIL] ! diagnostics_conv.o  : update task failed
[FAIL] ! diagnostics_lscld.o : update task failed
[FAIL] ! diagnostics_lsrain_mod.o: update task failed

The same error occurs for several modules as listed at the bottom of the error message. As far as I'm aware, these errors don't show up when I run a similar but N216-resolution suite.

Many thanks in advance!

Cheers
Markus

Change History (5)

comment:1 Changed 5 months ago by grenville

please set permissions on ARCHER /home and /work so we can read files there.

chmod -R g+rX /home/n02/n02/<username>
chmod -R g+rX /work/n02/n02/<username>

comment:2 Changed 5 months ago by mtodt

Sorry! Changed that.

Cheers
Markus

comment:3 Changed 5 months ago by grenville

Markus

I copied your job and the build worked OK for me. Please try a completely fresh build (rose suite-run —new)

Grenville

comment:4 Changed 5 months ago by mtodt

Hi Grenville

The build was indeed successful using rose suite-run —new. Thanks!

Cheers
Markus

comment:5 Changed 5 months ago by grenville

  • Resolution set to answered
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.