Opened 5 weeks ago

Closed 5 weeks ago

#3073 closed help (fixed)

fcm_make2 fails

Reported by: MJohnston1 Owned by: um_support
Component: UM Model Keywords: fcm_make2
Cc: Platform: ARCHER
UM Version: 10.9

Description

Good Afternoon,

I've just copied a previously working suite (u-bn885) to change the grid spacing from 800 to 100 m as I've done previously (u-bo593). The suite is now failing with the following message in the fcm_make2 stage:

[FAIL] use = /home2/n02/n02/umtest/cylc-run/vn10.9_prebuilds/share/fcm_make_ncas_xc30_cce_um_high_omp: incorrect value in declaration
[FAIL] config-file=/work/n02/n02/xb899100/cylc-run/u-bo593/share/fcm_make/fcm-make2.cfg:6
[FAIL] /home2/n02/n02/umtest/cylc-run/vn10.9_prebuilds/share/fcm_make_ncas_xc30_cce_um_high_omp/.fcm-make/ctx.gz: cannot retrieve cache
[FAIL] No such file or directory at /fs2/y07/y07/umshared/software/fcm-2017.10.0/bin/../lib/FCM/System/Make/Share/Dest.pm line 106, <$handle> line 6.

[FAIL] fcm make -C /work/n02/n02/xb899100/cylc-run/u-bo593/share/fcm_make -n 2 -j 6 --ignore-lock # return-code=2
Received signal ERR
cylc (scheduler - 2019-11-11T19:25:07Z): CRITICAL Task job script received signal ERR at 2019-11-11T19:25:07Z
cylc (scheduler - 2019-11-11T19:25:07Z): CRITICAL failed at 2019-11-11T19:25:07Z

I've checked out a suite that I knew to work (u-bh194) and tried to run it and got the same message.

Possibly related, I'm now getting an error message 'Could not find metadata for um-crmstyle/HEAD' when I ope the suite editor in rose.

I'm not sure that I follow what either message is referring to, please can you advise on how to remedy this?

Best Regards,
Michael

Attachments (1)

SuiteEditorError.png (7.4 KB) - added by MJohnston1 5 weeks ago.
Error Message when opening rose suite editor

Download all attachments as: .zip

Change History (6)

Changed 5 weeks ago by MJohnston1

Error Message when opening rose suite editor

comment:1 Changed 5 weeks ago by grenville

Michael

Try setting PREBUILD to be empty in the suite.rc file, then do a full rebuild rose suite-run —new.

Grenville

comment:2 Changed 5 weeks ago by MJohnston1

Thanks Grenville,

I've just given this a try. Suite u-bo593 now fails with walltime 7251 exceeded limit 7200 on the fcm_make2 stage.

comment:3 Changed 5 weeks ago by grenville

ARCHER is going slowly; my jobs are doing the same - try again later

comment:4 Changed 5 weeks ago by dcase

Michael (and anyone else who is searching tickets for prebuilds related fails),

although the prebuilds were never officially supported on ARCHER, there are quite a few versions of the UM for which they used to exist. Unfortunately, due to the system's age and use, the disk has hit the file limit and has become unusable without stronger efforts to tidy things. In order to help keep ARCHER running smoothly, I've tarred up the prebuild directories, and so people shouldn't use prebuilds henceforth.

Michael- sorry if this makes your build slower, but with everyone stressing to do their last calculations before the computer is replaced, I didn't want people's jobs crashing due to the disk and hence took this action. I'll follow this ticket, so include any updates as they happen.

Dave

comment:5 Changed 5 weeks ago by MJohnston1

  • Resolution set to fixed
  • Status changed from new to closed

Thanks Grenville and Dave - this problem is now solved on my part.

Note: See TracTickets for help on using tickets.