Opened 11 years ago

Closed 8 years ago

#308 closed error (fixed)

Error when using gregorian calendar

Reported by: ggxjd Owned by: jeff
Component: UM Model Keywords: Gregorian
Cc: Platform:
UM Version: 4.5

Description (last modified by ros)

Hi,
I've got a problem when I run the LAM for individual months like Feb with less than 31 days with the ERA-40 boundary conditions (using a Gregorian calendar). The dump is written for that month and I get the following error (at the bottom) It's like the experiment wants to carry on past the 28 days of Feb. This does not happen with the months that are 31 days in length. Only those with 28 or 30. My jobid is tcsmc.

I have the run length set to 1 month rather than explicitly stating say 28 days run length for the shorter months. Have you encountered this problem before? I'm not sure if my job is set up correctly for running with a Gregorian calendar.

Cheers
Jonny

DUMPCTL: Opening new file tcsmca@daj7931 on unit                     22
 MODEL DUMP SUCCESSFULLY WRITTEN - 18986617 WORDS TO UNIT 22

 Number of Words Written to Disk was  18988472
 REPLANCA: UPDATE REQUIRED FOR FIELD                     7
  REPLANCA - time interpolation for field                      7
  time,time1,time2    949236.000000000        949200.000000000    
   949944.000000000    
  hours,int,period                     42                     1
                    12
  Information used in checking ancillary data set:
  position of lookup table in dataset:                    39
  Position of first lookup table referring to data type                      1
  Interval between lookup tables referring to data type                     19
  Number of steps                     2
  STASH code in dataset                     60   STASH code requested
                    60
 'Start' position of lookup tables for dataset in overall lookup array
                     1
 REPLANCA: UPDATE REQUIRED FOR FIELD                    27
  REPLANCA - time interpolation for field                     27
  time,time1,time2    948876.000000000        948564.000000000    
   949236.000000000    
  hours,int,period                     42                     1
                    12
  Information used in checking ancillary data set:
  position of lookup table in dataset:                  3928
  Position of first lookup table referring to data type                      1
  Interval between lookup tables referring to data type                      3
  Number of steps                  1309
  STASH code in dataset                     31   STASH code requested
                    31
 'Start' position of lookup tables for dataset in overall lookup array
                  1891
 REPLANCA: UPDATE REQUIRED FOR FIELD                    28
  REPLANCA - time interpolation for field                     28
  time,time1,time2    948876.000000000        948564.000000000    
   949236.000000000    
  hours,int,period                     42                     1
                    12
  Information used in checking ancillary data set:
  position of lookup table in dataset:                  1310
  Position of first lookup table referring to data type                      1
  Interval between lookup tables referring to data type                      1
  Number of steps                  1309
  STASH code in dataset                     24   STASH code requested
                    24
 'Start' position of lookup tables for dataset in overall lookup array
                   229
 REPLANCA: UPDATE REQUIRED FOR FIELD                    29
  REPLANCA - time interpolation for field                     29
  time,time1,time2    948876.000000000        948564.000000000    
   949236.000000000    
  hours,int,period                     42                     1
                    12
  Information used in checking ancillary data set:
  position of lookup table in dataset:                  3930
  Position of first lookup table referring to data type                      3
  Interval between lookup tables referring to data type                      3
  Number of steps                  1309
  STASH code in dataset                     32   STASH code requested
                    32
 'Start' position of lookup tables for dataset in overall lookup array
                  1891
 *********************************************************************************
 Model aborted with error code -   11 Routine and message:-
         UP_BOUND: No boundary data update data left      for limited area model
 *********************************************************************************

Change History (12)

comment:1 in reply to: ↑ description Changed 11 years ago by jeff

  • Owner changed from um_support to jeff
  • Status changed from new to accepted

Replying to ggxjd:

Hi Jonny

*
Model aborted with error code - 11 Routine and message:-

UP_BOUND: No boundary data update data left for limited area model

*

This is the important error message, so there is a problem with reading your LBC file. Without seeing your file its hard to know exactly what is going wrong, but one thing it could be is if your LBC file uses the 360 day calendar. I am not sure what would happen in this case but I think there would be problems. I would need to see your LBC file and the the full output file to get any further with this query.

Jeff.

comment:2 Changed 11 years ago by ggxjd

If i put these files on my home directory on puma could you view them? Also, what do you mean by 'full output file'? Do you just meen the whole .leave file?

Cheers
Jonny

comment:3 Changed 11 years ago by jeff

Hi

Yes if you put the files on puma I will be able to read them. Yes I mean the .leave file. Thanks.

Jeff.

comment:4 Changed 11 years ago by ggxjd

Hi Jeff,
I've put the lbc file: adqcma.pih9210.lbc, and the .leave file: tcsmc000.tcsmc.d09222.t174200.leave on puma in my home directory. user ggxjd.

Cheers
Jonny

comment:5 Changed 11 years ago by jeff

Can you change the permissions on tcsmc000.tcsmc.d09222.t174200.leave so I can read it, thanks.

Jeff.

comment:6 Changed 11 years ago by ggxjd

Hi Jeff,
Sorry, I've changed the permissions now.

Cheers
Jonny

comment:7 Changed 11 years ago by jeff

I've looked at your files and I can't see anything obviously wrong. In order to find out what is happening here I really need to be able to run your job and put some print statement in the code. Is there anyway to do this, e.g. get me an account at Bristol?

Jeff.

comment:8 Changed 11 years ago by ggxjd

Hi Jeff,
I've made some inquiries and I think it would be difficult to get you an account on the local resources with out a project code and a letter from a PI to give to the HPC people. I'll have a talk with Paul Valdes when he gets back from holiday to see if this is possible.

I'll be in touch soon. Could this sort of error be caused by a miss match between the run length and the stash set-up?

Cheers
Jonny

comment:9 Changed 11 years ago by ggxjd

Hi Jeff,
to get an account on Bluecrystal phase 2 which I'm using, go to the following:

https://www.acrc.bris.ac.uk/login-area/apply.cgi?ticket=ST-46645019-N5jmQT9hcqpFMZrZ2NRx.

The project code is GLAC002821 and you'll want ksh as this is the environment I have chosen.

Let me know how you get on and we can set up your environment like mine to reproduce the problem.

Cheers
Jonny

comment:11 Changed 11 years ago by ggxjd

Not sure,

try:
https://www.acrc.bris.ac.uk/login-area/apply.cgi

If this doesn't work I'll get your details and try and apply for it myself.

Cheers
Jonny

comment:12 Changed 8 years ago by ros

  • Description modified (diff)
  • Resolution set to fixed
  • Status changed from accepted to closed
Note: See TracTickets for help on using tickets.