Opened 3 weeks ago

Closed 3 weeks ago

#3085 closed help (fixed)

X11 authentication fail when starting Rose on PUMA

Reported by: mtodt Owned by: um_support
Component: Rose/Cylc Keywords: Rose PUMA X11
Cc: Platform: PUMA
UM Version:

Description

Hi

Since Friday I cannot start Rose GUIs on PUMA with the following error message popping up:

X11 connection rejected because of wrong authentication.
/usr/local/python/lib/python2.6/site-packages/gtk-2.0/gtk/__init__.py:57: GtkWarning: could not open display
  warnings.warn(str(e), _gtk.Warning)
/home/fcm/rose-2016.11.1/lib/python/rose/gtk/splash.py:57: Warning: invalid (NULL) pointer instance
  super(SplashScreen, self).__init__()
/home/fcm/rose-2016.11.1/lib/python/rose/gtk/splash.py:57: Warning: g_signal_connect_data: assertion `G_TYPE_CHECK_INSTANCE (instance)' failed
  super(SplashScreen, self).__init__()
/home/fcm/rose-2016.11.1/lib/python/rose/gtk/splash.py:92: GtkWarning: Screen for GtkWindow not set; you must always set
a screen for a GtkWindow before using the window
  self.show()
/home/fcm/rose-2016.11.1/lib/python/rose/gtk/splash.py:92: GtkWarning: IA__gdk_screen_get_display: assertion `GDK_IS_SCREEN (screen)' failed
  self.show()
/home/fcm/rose-2016.11.1/lib/python/rose/gtk/splash.py:92: GtkWarning: IA__gdk_display_get_pointer: assertion `GDK_IS_DISPLAY (display)' failed
  self.show()
/home/fcm/rose-2016.11.1/lib/python/rose/gtk/splash.py:92: GtkWarning: IA__gdk_screen_get_n_monitors: assertion `GDK_IS_SCREEN (screen)' failed
  self.show()
/home/fcm/rose-2016.11.1/lib/python/rose/gtk/splash.py:92: GtkWarning: IA__gdk_screen_get_monitor_geometry: assertion `GDK_IS_SCREEN (screen)' failed
  self.show()
/home/fcm/rose-2016.11.1/lib/python/rose/gtk/splash.py:92: GtkWarning: IA__gdk_screen_get_default_colormap: assertion `GDK_IS_SCREEN (screen)' failed
  self.show()
/home/fcm/rose-2016.11.1/lib/python/rose/gtk/splash.py:92: GtkWarning: IA__gdk_colormap_get_visual: assertion `GDK_IS_COLORMAP (colormap)' failed
  self.show()
/home/fcm/rose-2016.11.1/lib/python/rose/gtk/splash.py:92: GtkWarning: IA__gdk_screen_get_root_window: assertion `GDK_IS_SCREEN (screen)' failed
  self.show()
/home/fcm/rose-2016.11.1/lib/python/rose/gtk/splash.py:92: GtkWarning: IA__gdk_window_new: assertion `GDK_IS_WINDOW (parent)' failed
  self.show()

Do I need to change any settings or account/login details? Many thanks in advance!

Cheers
Markus

Change History (6)

comment:1 Changed 3 weeks ago by dcase

There are a few older tickets with similar issues; these were usually caused by running out of disk space. Is it possible to delete some old data and try again?

Dave

comment:2 Changed 3 weeks ago by mtodt

Hi Dave

I tried that already. I had > 1000MB in my home directory and thought that might cause the problem, but the error still occurs after reducing to ~700MB. Or is that still too much?

Cheers
Markus

comment:3 Changed 3 weeks ago by dcase

That is what I would have done. I think that you've deleted enough, but there's possibly something fiddly which happened during the period in which you were over the limit. If you run ps -flu mtodt there are several old python processes from last Friday. Perhaps the next thing to do is to kill all of these (and all non-essential processes), then log out and back in again, and start afresh.

Sometimes brute force solutions can work.

comment:4 Changed 3 weeks ago by andy

Hi Markus,

Your quota looks okay but just in case I have increased it from 1GB to 3GB. Try again and see if that helps. If not have you used ssh -X to get into puma? Sometime logging out of your computer completely and starting again helps.

Cheers
Andy

comment:5 Changed 3 weeks ago by mtodt

Hi guys

I'v killed the python jobs, logged out and back in again, and can open Rose now. Thanks a lot for helping me immediately!

Cheers
Markus

comment:6 Changed 3 weeks ago by dcase

  • Resolution set to fixed
  • Status changed from new to closed

No probs. If you don't mind then I'm closing the ticket- feel free to open it if you get other problems later on.

Note: See TracTickets for help on using tickets.