Opened 3 weeks ago

Closed 2 weeks ago

#3088 closed help (fixed)

Rose fcm fails to obtain file

Reported by: jkaduk Owned by: um_support
Component: Rose/Cylc Keywords:
Cc: Platform: JASMIN
UM Version:

Description

Hello

I am trying to get a suite to run. I checked the trunk version of u-al752 out and did only very minor modifications that should all relate only to adapting the user name and dirctories.

THe configuration is there:

/home/users/jkaduk/roses/u-al752

When I run the suite: rose-suite.conf it stops with:
[FAIL] file:bin/fluxnet_evaluation.py=source=fcm:jules.x_br/pkg/karinawilliams/r6716_python_packages/share/fluxnet_evaluation.py@15046: bad or missing value

Somehow it seems that I do not get the python script copied. At least noting is in ~/cylc-run/u*/bin

It is like the very first real thing that should be done fails.

I tried various things:

I logged out and logged back in, entered my MOSRS password, got my MOSRS user name recognized, Subversion and Rosie passwords cached.

I listed the modules - only 2 no jaspy. I would expect a few more modules, no?

My username on MOSRS is different from the one on JASMIN. Will that be a problem?

I tried 'mosrs-setup-gpg-agent' but nothing seems to happen.

I am not entirely sure that I have access to the jules Group Workspace.

THe interaction is below.

Any suggestiong where the FAIL comes from would be great.
Thank you,

Best,
Joerg

[jkaduk@jasmin-login1 ~]$ ssh -AX jasmin-cylc

Last login: Tue Nov 26 12:45:45 2019 from jasmin-login1-panfs.jc.rl.ac.uk

RAL High Performance Computing Services Group
Configured by PXE/Kickstart: 2014-08-04 11:09
Admin contact: Peter Chiu <peter.chiu@…>

Additional information about JASMIN can be found at: http://jasmin.ac.uk
For support please contact CEDA Helpdesk: support@…

Met Office Science Repository Service password:
Subversion password cached
https://code.metoffice.gov.uk/rosie/u/hello: Hello joergkaduk
Rosie password cached

[jkaduk@jasmin-cylc ~]$ module list
Currently Loaded Modulefiles:

1) lsfmodules/9.1 2) lotus-mpi/8.2

[jkaduk@jasmin-cylc u-al752]$ rose suite-run
[INFO] export CYLC_VERSION=7.8.1
[INFO] export ROSE_ORIG_HOST=jasmin-cylc.ceda.ac.uk
[INFO] export ROSE_SITE=
[INFO] export ROSE_VERSION=2019.01.0
[INFO] create: log.20191126T125547Z
[INFO] delete: log
[INFO] symlink: log.20191126T125547Z ⇐ log
[INFO] log.20191126T125339Z.tar.gz ⇐ log.20191126T125339Z
[INFO] delete: log.20191126T125339Z/
[INFO] create: log/suite
[INFO] create: log/rose-conf
[INFO] symlink: rose-conf/20191126T125547-run.conf ⇐ log/rose-suite-run.conf
[INFO] symlink: rose-conf/20191126T125547-run.version ⇐ log/rose-suite-run.version
[FAIL] file:bin/fluxnet_evaluation.py=source=fcm:jules.x_br/pkg/karinawilliams/r6716_python_packages/share/fluxnet_evaluation.py@15046: bad or missing value

Change History (6)

comment:1 Changed 3 weeks ago by jkaduk

I also ran mosrs-check (output below). I could not see a problem. No change to the error…

[jkaduk@jasmin-cylc ~]$ mosrs-check
Checking your setup for accessing the Met Office Science Repository Service (SRS)
[INFO] svn, version 1.8.19 (r1800620)
[INFO] Rose 2019.01.0 (/apps/contrib/metomi/rose-2019.01.0)
[INFO] ~/.subversion/servers: SRS username configured as "joergkaduk"
[INFO] ~/.subversion/auth/svn.simple/2be6a67d04b1c8c6d879daafa52fd762: password stored in gpg-agent
[INFO] gpg-agent: password cached
[INFO] Subversion access successful
[INFO] Rosie "u" access successful

comment:2 Changed 3 weeks ago by grenville

Should it not be

fcm:jules.x_br/pkg/karinawilliams/r6715_python_packages/share/fluxnet_evaluation.py@15046

I don't see a r6716 under Karinawilliams

Grenville

comment:3 Changed 2 weeks ago by jkaduk

THank you! Looks like, indeed! I do not know, what happened there. I thought I just checked the suite out.
Anyway works now!

comment:4 Changed 2 weeks ago by dcase

Joerg,

I'm glad that problem was solved. If you have future issues, which are JULES specific, there is are some email lists which you can sign up to here: https://code.metoffice.gov.uk/trac/jules . There is a JULES expert on this channel, but there are many more on those email lists, so you might want to check them out if you haven't already done so.

Dave

comment:5 Changed 2 weeks ago by pmcguire

Hi Joerg
I am glad you got it working! Thanks, Grenville and Dave for the help.
I checked the suite u-al752 and it should indeed be checking the Python code out from the r6715 path instead of the r6716 path.
One way to help in debugging things like this is to use the fcm command at the jasmin-cylc command line to explore the MOSRS repository a bit, and to check if the file is there and if your MOSRS account is working.
See below for some examples.
I will close the ticket now.
Patrick

[pmcguire@jasmin-cylc u-al752]$ fcm list fcm:jules.x_br/pkg/karinawilliams/r6715_python_packages/share/fluxnet_evaluation.py@13471
fluxnet_evaluation.py
[pmcguire@jasmin-cylc u-al752]$ fcm list fcm:jules.x_br/pkg/karinawilliams/r6715_python_packages/share
README
compare_sinclair_and_jules_p0.py
convertpoints2grid.py
fluxnet_evaluation.py
huntingford2015_equations.py
jules.py
make_time_coord.py
parallelise.py
soil_cosby_parameters.py
soil_water_stress_factors.py
test_fluxnet_evaluation.py
test_huntingford2015_equations.py
test_soil_cosby_parameters.py
test_soil_water_stress_factors.py
testdata/
[pmcguire@jasmin-cylc u-al752]$ fcm list fcm:jules.x_br/pkg/karinawilliams/r6716_python_packages/share/fluxnet_evaluation.py@13471
svn: warning: W160013: URL 'https://code.metoffice.gov.uk/svn/jules/main/branches/pkg/karinawilliams/r6716_python_packages/share/fluxnet_evaluation.py' non-existent in revision 13471
svn: E200009: Could not list all targets because some targets don't exist
[FAIL] svn list https://code.metoffice.gov.uk/svn/jules/main/branches/pkg/karinawilliams/r6716_python_packages/share/fluxnet_evaluation.py@13471 # rc=1

[pmcguire@jasmin-cylc u-al752]$ fcm export fcm:jules.x_br/pkg/karinawilliams/r6715_python_packages/share/fluxnet_evaluation.py@13471
A    fluxnet_evaluation.py
Export complete.

comment:6 Changed 2 weeks ago by pmcguire

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.