Opened 3 weeks ago

Closed 13 days ago

#3090 closed help (fixed)

Login to ARCHER fails when rose suite-run

Reported by: mtodt Owned by: um_support
Component: Rose/Cylc Keywords: ARCHER Rose Suite Run
Cc: Platform: ARCHER
UM Version:

Description

Hi

I'm trying to run a suite on ARCHER from PUMA but get the following error:

[FAIL] bash -ec H=$(rose\ host-select\ archer);\ echo\ $H # return-code=1, stderr=
[FAIL] [WARN] login7.archer.ac.uk: (ssh failed)
[FAIL] [WARN] login2.archer.ac.uk: (ssh failed)
[FAIL] [WARN] login1.archer.ac.uk: (ssh failed)
[FAIL] [WARN] login4.archer.ac.uk: (ssh failed)
[FAIL] [WARN] login6.archer.ac.uk: (ssh failed)
[FAIL] [WARN] login.archer.ac.uk: (ssh failed)
[FAIL] [WARN] login8.archer.ac.uk: (ssh failed)
[FAIL] [WARN] login3.archer.ac.uk: (ssh failed)
[FAIL] [WARN] login5.archer.ac.uk: (ssh failed)
[FAIL] [FAIL] No hosts selected.

This is independent of which suite I'm trying to run. However, I can "manually" ssh to ARCHER so my account still works. Many thanks in advance for your help!

Cheers
Markus

Change History (10)

comment:1 Changed 2 weeks ago by grenville

Markus

If the problem persists, a hack would be to change in site/archer.rc:

host = $(rose host-select archer)

to

host = login.archer.ac.uk

Grenville

comment:2 Changed 2 weeks ago by mtodt

Hi Grenville

Thanks! The problem still persisted today, so I changed the line in archer.rc. However, now the following error message occurs when trying to run:

[INFO] create: log.20191128T124526Z
[INFO] delete: log
[INFO] symlink: log.20191128T124526Z <= log
[INFO] log.20191128T121251Z.tar.gz <= log.20191128T121251Z
[INFO] delete: log.20191128T121251Z/
[INFO] create: log/suite
[INFO] create: log/rose-conf
[INFO] symlink: rose-conf/20191128T124526-run.conf <= log/rose-suite-run.conf
[INFO] symlink: rose-conf/20191128T124526-run.version <= log/rose-suite-run.version
[INFO] export CYLC_VERSION=6.11.4
[INFO] export ROSE_ORIG_HOST=puma
[INFO] export ROSE_VERSION=2016.11.1
[INFO] install: site
[INFO]     source: /home/mtodt/roses/u-bp248/site
[FAIL] cylc validate -v --strict u-bp248 # return-code=1, stderr=
[FAIL] 'ascii' codec can't encode character u'\xa0' in position 7187: ordinal not in range(128)

Cheers
Markus

comment:3 Changed 2 weeks ago by grenville

try retyping the lines

#host = $(rose host-select archer)
host = login.archer.ac.uk

that worked for me

Grenville

comment:4 Changed 2 weeks ago by mtodt

Thanks, Grenville! I got past the previous error this time, but it seems I don't have permission to run on ARCHER:

[FAIL] ssh -oBatchMode=yes login.archer.ac.uk bash --login -c \'ROSE_VERSION=2016.11.1\ rose\ suite-run\ -v\ -v\ --name=u-bp248\ --run=run\ --remote=uuid=714dfb38-b528-4d36-aa60-5990c67229eb,root-dir=$DATADIR\' # return-code=255, stderr=
[FAIL] --------------------------------------------------------------------------------
[FAIL] This is a private computing facility. Access to this service is limited to those
[FAIL] who have been granted access by the operating service provider on behalf of the
[FAIL] contracting authority and use is restricted to the purposes for which access was
[FAIL] granted. All access and usage are governed by the terms and conditions of access
[FAIL] agreed to by all registered users and are thus subject to the provisions of the
[FAIL] Computer Misuse Act, 1990 under which unauthorised use is a criminal offence.
[FAIL] 
[FAIL] If you are not authorised to use this service you must disconnect immediately.
[FAIL] --------------------------------------------------------------------------------
[FAIL] 
[FAIL] Permission denied (publickey,keyboard-interactive).

As before, I can ssh "manually" to login.archer.ac.uk. Should I create a new ssh key?

comment:5 Changed 2 weeks ago by grenville

what exactly do you type on PUMA to login to ARCHER?

comment:6 Changed 2 weeks ago by mtodt

I type

ssh mtodt@login.archer.ac.uk

and had set up an ssh key as outlined in the practical session doc of the NCAS UM introduction.

comment:7 Changed 2 weeks ago by grenville

Sounds like you need to create an ssh config file — your suite doesn't understand the mtodt bit.

in your .ssh directory on PUMA, create a file called config with the following

Host login.archer.ac.uk
User mtodt

Host *
ForwardAgent? no
ForwardX11 yes
ForwardX11Trusted yes

then try to login to archer with

ssh login.archer.ac.uk

this should allow your suite to run too

Grenville

comment:8 Changed 2 weeks ago by grenville

ForwardAgent? should not have a ? — that's a wiki artifact

comment:9 Changed 2 weeks ago by mtodt

Hi Grenville

I created the config file, but still get the same error as before. I actually was already able to login via ssh login.archer.ac.uk previously, I tested that before creating the config file. What's even more puzzling is that I had been able to run suites on ARCHER until about a week or so ago.

Cheers
Markus

Last edited 2 weeks ago by mtodt (previous) (diff)

comment:10 Changed 13 days ago by mtodt

  • Resolution set to fixed
  • Status changed from new to closed

Issue stemmed from .ssh/environment.puma. Solved now.

Note: See TracTickets for help on using tickets.