Opened 4 months ago

Closed 4 months ago

#3104 closed help (fixed)

Nesting Suite Tutorial 2019 - DM Initial Conditions File

Reported by: Jez.Carter Owned by: um_support
Component: Nesting Suite Keywords: Nested
Cc: Platform: Monsoon2
UM Version:

Description

Dear CMS,

I've been trying to follow the following tutorial on running nested suites (https://code.metoffice.gov.uk/trac/rmed/wiki/suites/nesting/worked_eg_2019). In the tutorial they run the driving model from analyses on disk (https://code.metoffice.gov.uk/trac/rmed/attachment/wiki/suites/nesting/worked_eg_2019/u-driving_rerun_anal_on_disk.2.png). When I try to run the suite with the exact same set-up as in task 1 of the tutorial I get the following error message (see attached), which I assume is linked to not being able to find the analyses data on disk file. Could you advise on how to resolve this issue?

Best wishes,
Jeremy

Attachments (2)

Screenshot from 2019-12-09 10-37-27.png (62.7 KB) - added by Jez.Carter 4 months ago.
Screenshot from 2019-12-09 13-06-41.png (94.6 KB) - added by Jez.Carter 4 months ago.

Download all attachments as: .zip

Change History (9)

Changed 4 months ago by Jez.Carter

comment:1 follow-up: Changed 4 months ago by dcase

I may have completely misunderstood you, but there are four files there:

ls -lht /projects/cascade/hadsw/um_analyses/       
total 96G
-rw-r--r-- 1 hadsw cascade 24G Jun  6  2017 20160819T1200Z_glm_t+0
-rw-r--r-- 1 hadsw cascade 24G Jun  6  2017 20160819T0000Z_glm_t+0
-rw-r--r-- 1 hadsw cascade 24G Jun  6  2017 20160818T1200Z_glm_t+0
-rw-r--r-- 1 hadsw cascade 24G Jun  6  2017 20160818T0000Z_glm_t+0

So aren't you supposed to pick one of those??

comment:2 in reply to: ↑ 1 Changed 4 months ago by Jez.Carter

Replying to dcase:

I may have completely misunderstood you, but there are four files there:

ls -lht /projects/cascade/hadsw/um_analyses/       
total 96G
-rw-r--r-- 1 hadsw cascade 24G Jun  6  2017 20160819T1200Z_glm_t+0
-rw-r--r-- 1 hadsw cascade 24G Jun  6  2017 20160819T0000Z_glm_t+0
-rw-r--r-- 1 hadsw cascade 24G Jun  6  2017 20160818T1200Z_glm_t+0
-rw-r--r-- 1 hadsw cascade 24G Jun  6  2017 20160818T0000Z_glm_t+0

So aren't you supposed to pick one of those??

So in the cycling options tab I've selected 20160818T0000Z (https://code.metoffice.gov.uk/trac/rmed/attachment/wiki/suites/nesting/worked_eg_2019/u-cycling1.png) so it should be able to find the file. I might be getting confused with why the error is arising in the first place?

comment:3 follow-up: Changed 4 months ago by dcase

Jeremy,

in your rose-suite-run.log file you'll see that the command rose host-select postproc is trying to be run, but cannot on this system. If you go to site/monsoon-cray-xc40/suite-adds.rc in your roses directory try the following:

  • change host = $(rose host-select {{IDL_SERVER}}) to host = {{IDL_SERVER}}
  • if this doesn't work then also change IDL_SERVER = "postproc" to IDL_SERVER = "localhost"

but if you find you have apps which are using a lot of resources, be wary of using the localhost.

Changed 4 months ago by Jez.Carter

comment:4 in reply to: ↑ 3 Changed 4 months ago by Jez.Carter

Replying to dcase:

Jeremy,

in your rose-suite-run.log file you'll see that the command rose host-select postproc is trying to be run, but cannot on this system. If you go to site/monsoon-cray-xc40/suite-adds.rc in your roses directory try the following:

  • change host = $(rose host-select {{IDL_SERVER}}) to host = {{IDL_SERVER}}
  • if this doesn't work then also change IDL_SERVER = "postproc" to IDL_SERVER = "localhost"

but if you find you have apps which are using a lot of resources, be wary of using the localhost.

After changing host = $(rose host-select {{IDL_SERVER}}) to host = {{IDL_SERVER}} it now starts running but fails with the new error I've attached.

comment:5 follow-up: Changed 4 months ago by dcase

If you read the job-activity.log you'll see that the charging code is set to 'collabtraining' which isn't accepted. You can change this to a group which you are a member of in the rose-suite.conf file

comment:6 in reply to: ↑ 5 Changed 4 months ago by Jez.Carter

Replying to dcase:

If you read the job-activity.log you'll see that the charging code is set to 'collabtraining' which isn't accepted. You can change this to a group which you are a member of in the rose-suite.conf file

Many thanks, this with the above seems to have resolved the issue.
Jez

comment:7 Changed 4 months ago by dcase

  • Resolution set to fixed
  • Status changed from new to closed

Jez,

I'll close this ticket, if you don't mind. It can be reopened if the issue comes up again.

Dave

Note: See TracTickets for help on using tickets.