Opened 3 months ago

Closed 3 months ago

#3116 closed help (fixed)

error using pp_merge

Reported by: ambrogio Owned by: um_support
Component: UM Tools Keywords:
Cc: Platform:
UM Version:

Description

Dear Helpdesk,

I am using the pp_merge routine, part of PPFileTools, to merge pp files and make them compatible for NDdiag use. I have already used this rouiune in the past without problems. Unfortunately I am now getting the error copied here:

readdataandOutput, error = 5016

Do you know what could be causing this? In case this is useful, the command I am giving is:

/home/users/ambrogio/programs/PP_tools_src/pp_merge ${expdir}/u-${job}/nddiag_ppfiles/ap_all_nddiag_${date}.pp ${expdir}/u-${job}/ap?.pp/ap?_nddiag_${date}/${job}*pp

where:

expdir=/gws/nopw/j04/cosmic/ambrogio/UM_data/
outdir=/users/ambrogio/NDdiag_files
job=bh377
date=200906_18

Please let me know if you want me to move these files to somewhere you have access to in case you want to check them.

Apologies for bothering with this (I hope it's not just a trivial mistake on my side!) and many thanks for your help

Ambrogio


Ambrogio Volonté
Research Scientist in Monsoon Observation and Modelling (INCOMPASS & COSMIC projects)
Room 125, Harry Pitt Building
Department of Meteorology
University of Reading

Change History (8)

comment:1 Changed 3 months ago by simon

Hi Ambrogio,

5016 is a Fortran error code indicating an unexpected end-of-file, usually due to file corruption. Could you check the integrity of the input files by some other means (xconv|iris|cf-python)? I don't have the necessary permissions to read them.

comment:2 Changed 3 months ago by ambrogio

Dear Simon,

Thank you very much for your reply. The pp files look ok when opened with Xconv.
Is there any location in Jasmin that you can access so that I can show you those files? Or otherwise I could copy them to my personal directory in Archer (in /work/n02/n02/).

Thanks again and sorry for the delay in getting back to you (I don't know why but I didn't get a notification after your reply)
Ambrogio

comment:3 Changed 3 months ago by simon

Hi,

It might be simpler if I am granted access to the cosmic group workspace on jasmin. Do you know the owner is?

comment:4 Changed 3 months ago by simon

Hi,

The issue is that the data is packed and pp_merge only worked with unpacked data. I've updated the code for packed data. It's available on http://cms.ncas.ac.uk/wiki/ToolsAndUtilities/PpFileTools

Alternatively you can unpack it using pp_unpack on the same page, or just write it unpacked from the model.

I have no idea if NDdiag requires unpacked data or not.

comment:5 Changed 3 months ago by ambrogio

Hi Simon,
thanks for this.

I've used the updated pp_merge on those files and it runs fine now.
However, I think NDdiag doesn't like the unpacked file that pp_merge generates as it is now giving me the following error:

"Fortran runtime error: I/O past end of record on unformatted file"

Could you try having a quick look at pp_unpack? I've downloaded it from the pp_tools web page but I am getting the errors copied below when trying to compile it with make

f95 -f77 -C -u -xcheck=%all -Xlistc -ftrap=common -g -xfilebyteorder=big4:%all -c unpackpp.F
f95: unrecognized option '-Xlistc'
f95: language filebyteorder=big4:%all not recognized
f95: language filebyteorder=big4:%all not recognized
f95: unpackpp.F: linker input file unused because linking not done

Many thanks again and sorry for bothering with this,
Ambrogio

comment:6 Changed 3 months ago by simon

Hi Ambrogio,

I've updated pp_unpack to F90 to cope with large files (it wouldn't have worked with your input files even if it did compile). It now lives in the PP_tools github repository. Update your copy with git pull origin master and rerun make Jasmin to compile.

comment:7 Changed 3 months ago by ambrogio

Hi Simon, thank you very much!

I've now managed to feed the file (unpacked and merged) into NDdiag and to generate an NDdiag-processed pp file.

Best wishes
Ambrogio

comment:8 Changed 3 months ago by simon

  • Resolution set to fixed
  • Status changed from new to closed

Excellent! I'll close the ticket.

Note: See TracTickets for help on using tickets.