Opened 8 months ago

Closed 6 months ago

#3148 closed help (answered)

Error from routine: WGDOS Packing (f_shum_wgdos_pack) stash 2351

Reported by: luciad Owned by: um_support
Component: Diagnostics Keywords: COSP WGDOS packing
Cc: Platform: ARCHER
UM Version: 11.1

Description

Hello,

I am using suite u-bq438, but atmos_main is not running because I am getting an error with COSP CloudSat? reflectivity diagnostic - stash 2351.
The error is:
????????????????????????????????????????????????????????????????????????????????
???!!!???!!!???!!!???!!!???!!! ERROR ???!!!???!!!???!!!???!!!???!!!
? Error code: 2
? Error from routine: WGDOS Packing (f_shum_wgdos_pack)
? Error message: Problem packing field…
? STASH: 2351
? Accuracy: -12
? Minimum: -0.1065085823E-21
? Maximum: 0.2158503248E+07
? Message: Unable to WGDOS pack to this accuracy
? Error from processor: 16
? Error number: 55
????????????????????????????????????????????????????????????????????????????????

I am wondering if this error comes from requesting the diagnostics output at 64 subcolumns and 85 vertical levels (see attached) needed for an offline calculation of warm rain diagnostics (stash 2468-2472)

Is there a way to fix this issue?

Thank you,
Lucia

Attachments (1)

Screenshot 2020-01-21 at 12.39.02.png (126.0 KB) - added by luciad 8 months ago.
DTHSUBC domain profile

Download all attachments as: .zip

Change History (9)

Changed 8 months ago by luciad

DTHSUBC domain profile

comment:1 Changed 8 months ago by grenville

Lucia

Sounds like diagnostic has produced wrong data — try to output unpacked and inspect the data.

Grenville

comment:2 Changed 8 months ago by luciad

Thanks Grenville,

Now I get the same error, but for different diagnostics - 2451, 2463 (etc) - which are 2D diagnostics. I am wondering if these are linked to the fact that I am using gregorian calendar on this suite (copy of Leighton's u-bo845). My suite on 360 day (u-bo228) works perfectly fine.

I put here again the error. I'm not sure if you can tell if it's related to the monthly means or other time profile (because I use for the same diagnostics also 3hrly and daily outputs)

Lucia

????????????????????????????????????????????????????????????????????????????????
???!!!???!!!???!!!???!!!???!!! ERROR ???!!!???!!!???!!!???!!!???!!!
? Error code: 2
? Error from routine: WGDOS Packing (f_shum_wgdos_pack)
? Error message: Problem packing field…
? STASH: 2463
? Accuracy: -32
? Minimum: 0.0000000000E+00
? Maximum: 0.1000000000E+01
? Message: Unable to WGDOS pack to this accuracy
? Error from processor: 144
? Error number: 55
????????????????????????????????????????????????????????????????????????????????

comment:3 Changed 8 months ago by grenville

Lucia

I think that the data has failed to pack because it is outside the expected range. Did you unpack stash 2351 - was the data OK?

Grenville

comment:4 Changed 8 months ago by luciad

Grenville,

The error for the stash 2351 doesn't appear after I changed the corresponding packing profile in the Model Output Stream to "Unpacked". But I don't know where I can find these unpacked data. The field files in the ~/History_Data/ are empty.

Due to the long wait in the standard queue, I am now working on the short queue…and the atmos_main doesn't even start running, it just fails directly.

Lucia

comment:5 Changed 8 months ago by luciad

I just realized that for these last diagnostics errors, the problem might be that the MODIS simulator was not activated - I will test it again and get back to you if the issue is still not solved.

Thank you

Lucia

comment:6 Changed 8 months ago by luciad

Hi Grenville,

I am still confrunted with the same error, with COSP stash 2351. Alejandro Bodas_Salcedo suggested that these packing problems are normally caused by either of these two reasons:
1) the simulator for which you have requested data is not switched on.
2) the time profile is requesting data on all time steps, and radiation is called with 'substepping' on.

I've checked again, and all the simulator switches are turned on (unless that option is somewhere overwritten in some conf file)

Alejandro also mentioned that unpacking the data is not solving the root cause of the error, as the model might just write garbage data, instead of the right output.

If you have any insight on why this error occurs, I would appreciate your help,

Lucia

comment:7 Changed 8 months ago by grenville

Lucia

stash 2351 is full of missing value indicators.

Do you get correct stash 2351 output if you exclude

branches/dev/luciadeaconu/vn11.1_vn11.1_ACURE_merged_code

from the build?

Grenville

comment:8 Changed 6 months ago by ros

  • Resolution set to answered
  • Status changed from new to closed

Closed due to lack of activity.

Note: See TracTickets for help on using tickets.