#3170 closed error (fixed)

Nested suite failure at fcst stage: failure to mode change in another layer

Reported by: wilhelmhodder Owned by: um_support
Component: UM Model Keywords: change mode, rbuffering, nested suite, um
Cc: Platform: Monsoon2
UM Version: 11.1

Description

Hello,

I am attempting to run a nested suite with the first domain at 0.04x0.04 horizontal resolution, however, it fails on the firt time step of the nest forecast stage, with this main error message:

???!!!???!!!???!!!???!!!???!!! ERROR ???!!!???!!!???!!!???!!!???!!!
? Error code: 1
? Error from routine: c_io_rbuffering_change_mode
? Error message: Failure to mode change in another layer means read buffer cannot be made consistent.
? Error from processor: 0
? Error number: 41
????????????????????????????????????????????????????????????????????????????????

It also brings up a series of exceptions a snapshot of which I've attached.

The only thing I can think of that I explicitly changed since the last time the forecast run worked fine, was that I switched the Gravity wave drag scheme from 4 to 5. I also generated new ancillaries after the GWD version change to be sure.

I am at a loss at what this error means.

Kind regards,
Will

Attachments (1)

Screenshot from 2020-01-31 16-36-50.png (165.2 KB) - added by wilhelmhodder 10 months ago.

Download all attachments as: .zip

Change History (7)

Changed 10 months ago by wilhelmhodder

comment:1 Changed 10 months ago by grenville

Will

What is the suite id?

Grenville

comment:2 Changed 10 months ago by wilhelmhodder

Hi Grenville,

The suite id is u-bk574.

Cheers

Will

comment:3 Changed 10 months ago by grenville

Will

See ticket #2560

looks like you have the same thing, set l_dump_output to something else in the um task - I don't know why your setting causes an error (or even if this is the cause, but Denis claimed it was)

Grenville

comment:4 Changed 10 months ago by wilhelmhodder

Grenville,

Thank you for assissting me with this.

I can't find l_dump_output in the namelist, but I do have i_dump_output which is currently set to "No dumping and meaning"; is this the the setting you are referring to? Also, is #2560 the ticket you intended to link me to? It leads me to a ticket on accessing python functionality on some platform.

Will

comment:5 Changed 10 months ago by grenville

OK i_dump_output (the i looks like an l in the rose gui) and ticket (typing problems!) #2650

The helpdesk is searchable - I found 2650 by searching for c_io_rbuffering_change_mode.

Grenville

comment:6 Changed 10 months ago by wilhelmhodder

  • Resolution set to fixed
  • Status changed from new to closed

Hi Grenville,

Just to update, I figured out what to change l_dump_output to without causing a problem. Thank you for your help.

I'm still interested why the variable caused an issue even when I switched off dumping and meaning, but that's something to figure out another day.

Best wishes,

Will

Note: See TracTickets for help on using tickets.