Opened 6 months ago

Closed 6 months ago

#3195 closed help (fixed)

cannot open umui on PUMA

Reported by: emxin Owned by:
Component: UMUI Keywords: umui problem
Cc: Platform: PUMA
UM Version:

Description

Hi there,
I can log onto PUMA, and then Met Office Science Repository Service (with password). However, on puma I could not open umui to submit job to ARCHER. umui normally worked well before, but I did not use PUMA for about 4 months. Can you help?
Regards,
Xin

Change History (5)

comment:1 Changed 6 months ago by grenville

Xin

Please send exactly what you see on PUMA when typing umui.

Grenville

comment:2 Changed 6 months ago by emxin

Hi Grenville,
the error message is shown below:
emxin@puma:/home> umui
Application initialization failed: no display name and no $DISPLAY environment variable
Error in startup script: invalid command name "option"

while executing

"option add *foreground $colours(enabled_fg)"

(procedure "entry_appearance" line 19)
invoked from within

"entry_appearance"

(file "/home/umui/umui/ghui2.0/tcl/entry.tcl" line 52)

Xin

comment:3 Changed 6 months ago by dcase

Xin,
you need to enable X11 forwarding. When you ssh, use the command ssh -Y [your name]@puma.nerc.ac.uk and this should work.

Dave

comment:4 Changed 6 months ago by emxin

Hi Dave,
Thank you for that. The problem solved.
Regards,
Xin

comment:5 Changed 6 months ago by dcase

  • Resolution set to fixed
  • Status changed from new to closed

I'll close the ticket then.
Best of luck with your simulations

Note: See TracTickets for help on using tickets.