Opened 9 months ago

Closed 9 months ago

#3196 closed help (fixed)

rose edit problem?

Reported by: ggxmy Owned by: ros
Component: Rose/Cylc Keywords:
Cc: Platform: Monsoon2
UM Version: 10.7

Description

Dear CMS,

I seem to have a trouble when I try to open some suites on rose gui on Monsoon. When I open my copy (u-br913) of u-bh468 and try to open um I get this message;

IOError: [Errno 2] No such file or directly: '/data/users/moci/CMIP6_rose-meta/um-atmos/HEAD/rose-meta.conf'

When I click OK and try to open namelist, I get a disorganised list of files like the attached image.

This may be because u-bh468 is a suite for different platform? In fact when I tried to open a suite for puma-ARCHER in the past the same thing happened without the warning like above.

I thought maybe I should replace meta data directory with /home/d03/myosh/roses/u-br913/meta but as soon as I delete the original path rose edit crashes (it says it crashed although it is still responding).

Please could you help me?

thanks,
Masaru

Attachments (1)

broken.list.view.of.rose.edit.png (43.4 KB) - added by ggxmy 9 months ago.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 9 months ago by ros

  • Owner changed from um_support to ros
  • Status changed from new to accepted

Hi Masaru,

That is a Met Office internal path. I'll look and see if I can find an equivalent on Monsoon.

Cheers,
Ros.

Changed 9 months ago by ggxmy

comment:2 Changed 9 months ago by ggxmy

  • Resolution set to fixed
  • Status changed from accepted to closed

in a/r/9/3/0/trunk/app/um/rose-app.conf

r58600	r64857	 
1	 	meta=/data/users/moci/CMIP6_rose-meta/um-atmos/HEAD

has been replaced by

 	1	meta=/projects/ukesm/jwalton/cmip6/rose-meta/um-atmos/HEAD

In br927 (the suite I'm currently working on and having the same problem with) I found a line

import=/data/users/moci/CMIP6_rose-meta/um-atmos/HEAD

in app/um/meta/rose-meta.conf . So I tried replacing this line with the following;

import=/projects/ukesm/jwalton/cmip6/rose-meta/um-atmos/HEAD

and the problem is now resolved!!! Closing the ticket.

Masaru

comment:3 Changed 9 months ago by ggxmy

Hi Ros.,

I thought I had solved this problem but now I think I might not have. Have you found the equivalent file to /data/users/moci/CMIP6_rose-meta/um-atmos/HEAD/rose-meta.conf on Monsoon? I now wonder

import=/projects/ukesm/jwalton/cmip6/rose-meta/um-atmos/HEAD

might not be the right one to use.

My suite u-br927 never runs after many attempts (see #3203). Martin Andrews at Met Office kindly checked the suite by copying it and porting back to Met Office Cray. He says it runs fine there. Here are the latest differences between my suite that doesn't run on Monsoon and his one that does run on Met Office Cray;

https://code.metoffice.gov.uk/trac/roses-u/changeset?reponame=&new=150357%40b%2Fs%2F1%2F6%2F0&old=150505%40b%2Fr%2F9%2F2%2F7

So there are minimal differences and this one above is among them. Please can you check again?

Thanks,
Masaru

comment:4 Changed 9 months ago by ggxmy

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:5 Changed 9 months ago by ros

Hi Masaru,

The metadata purely affects how things are displayed (and includes info on valid settings) in the rose edit GUI and doesn't impact variable values.

I have a copy of the metadata directory at ~rhatcher/meta/moci/CMIP6_rose-meta/.... which is the same as Jeremy's apart from the valid range of one variable. You are welcome to switch to it and eliminate it from your investigation.

Cheers,
Ros.

comment:6 Changed 9 months ago by ros

Further to this I confirm that Jeremy's metadata directory is identical to that which Martin used at the MO.

Cheers,
Ros.

comment:7 Changed 9 months ago by ggxmy

Thank you very much for looking into this, Ros. So here is the latest differences between my suite and Martin's.

https://code.metoffice.gov.uk/trac/roses-u/changeset?reponame=&new=150357%40b%2Fs%2F1%2F6%2F0&old=150571%40b%2Fr%2F9%2F2%2F7

I can't see any more difference that might potentially affect the run. As shown in #3203, the process 'couple' crashes and ocean.output shows an error with an unphysical value of zonal velocity.

  stpctl: the zonal velocity is larger than 20 m/s
  ======
 kt=     3 max abs(U):   5190.    , i j k:   171   82    1

Any idea?

Masaru

comment:8 Changed 9 months ago by ggxmy

  • Resolution set to fixed
  • Status changed from reopened to closed

Helped in #3203. closing.

Note: See TracTickets for help on using tickets.