Opened 5 months ago

Closed 5 months ago

#3202 closed help (answered)

RosePopenError

Reported by: ggxmy Owned by: ros
Component: Rose/Cylc Keywords:
Cc: Platform: Monsoon2
UM Version: 10.7

Description

Dear CMS,

I'm trying to port a Met Office GC3.1 SenarioMIP suite u-bj611 to Monsoon. I compared it with a suite on Monsoon and modified it. My suite id is u-br927. When I tried to run it it returns an error like this;

RosePopenError?: cylc validate -o /working/d03/myosh/jtmp/tmp.wlcFOaxnKp/tmpmUonpv —strict u-br927, stderr=Jinja2Error

The attached image contains a little more details.

This is similar problem as #3189 so is it related to the land cover data? But there is no v2 data for SSP126 on Monsoon…

ll /projects/ancils/cmip6/ancils/n96e/ssp126/LandCover
total 4
drwxr-xr-x 2 hdyson ancils 4096 Dec  6 14:37 v1

Could the data placed there? Or should I do anything else to conquer this?

Thanks,
Masaru

Attachments (1)

rosepopenerror.jpeg (51.6 KB) - added by ggxmy 5 months ago.

Download all attachments as: .zip

Change History (6)

Changed 5 months ago by ggxmy

comment:1 Changed 5 months ago by ros

Hi Masaru,

There's usually more information about the error further down the traceback. This type of error usually points to a syntax error in the suite.rc file.

Regards,
Ros.

comment:2 Changed 5 months ago by ggxmy

HI Ros.,

If you saw the attached image that is all I got in that window. I can't find an error message in

/projects/ukca-leeds/myosh/cylc-run/u-br927/log/

I can't tell what's wrong in the suite.rc file. Could you please check the job directory or tell me where/what I should check?

In any case, I need a v2 land cover file, don't I? Maybe I can use historical or time slice data instead of SSP data?

Masaru

comment:3 Changed 5 months ago by ros

  • Component changed from UM Model to Rose/Cylc
  • Owner changed from um_support to ros
  • Status changed from new to accepted

Hi Masaru,

Sorry, for some reason it was slow showing me there was an attachment.
Ok so the problem is you have added a new site but not added an appropriate site file for it in the site directory. The error message is saying it can't find a file called site/meto_monsoon.rc where all the platform specific settings are found.

For consistency with other Monsoon suites I would change the value of SITE that you added in the metadata file to be monsoon not meto_monsoon. Then you need to add a file called monsoon.rc in the site directory. Usually it's easiest to copy the meto_cray.rc and modify as appropriate.

What Monsoon suite have you been comparing with?

Cheers,
Ros.

comment:4 Changed 5 months ago by ggxmy

Hi Ros.,

I initially followed the change set in u-ar930. But the UM version is slightly different and rose edit look a bit different as well. So I searched vn10.7 suite for Monsoon and found u-ay492.

So maybe I can copy meto_cray.rc and meto_cray_restart.rc as monsoon.rc and monsoon_restart.rc in br927 and apply the differences between cray and monsoon in ar930.

The only difference between meto_cray.rc and meto_monsoon.rc (both in ar930) is this line;

58c58
<             batch system = slurm
---
>             batch system = background

The line "batch system = slurm" is in meto_cray.rc of br927 as well so I can simply change this to "background".

There is no difference between meto_cray_restart.rc and meto_monsoon_restart.rc so I don't need to modify monsoon_restart.rc at all, right?

I'll try and see what happens.

thanks,
M

comment:5 Changed 5 months ago by ggxmy

  • Resolution set to answered
  • Status changed from accepted to closed

Now I get a different problem. So I'll open a new ticket for it.

Thank you for your help.
Masaru

Note: See TracTickets for help on using tickets.