Opened 3 months ago

Closed 3 months ago

#3217 closed help (fixed)

No hosts selected on archer

Reported by: luciad Owned by: um_support
Component: PUMA Keywords: login fail
Cc: Platform: ARCHER
UM Version: 11.1

Description

Hello,

I am trying to run a suit from pumatest on archer, but I get the 'No hosts selected' error. I have tried all the possible ways to fix it following different ticket suggestions (#3162, #3090) and the CMS configuration steps (http://cms.ncas.ac.uk/wiki/RoseCylc/Hints#Settinguprosehost-selectarcher), without success. When I type 'rose host-select' I get [FAIL] No (default) host specified.

Could you help me solve this issue?

Thank you,
Lucia

Change History (5)

comment:1 Changed 3 months ago by ros

Hi Lucia,

Can you check that your ssh-agent is still up and running? I.e can you run ssh login.archer.ac.uk and not be prompted for password or passphrase.

Cheers,
Ros.

comment:2 Changed 3 months ago by luciad

Hi Ros,

I've tested that but it asks for a password. So after I've done 'rose host-select' and added all the ARCHER hosts. This still failed.

I also did ssh-agent:

SSH_AUTH_SOCK=/tmp/ssh-GWwcIX8r5XsI/agent.16537; export SSH_AUTH_SOCK;
SSH_AGENT_PID=16538; export SSH_AGENT_PID;
echo Agent pid 16538;

and ssh-add:
Error connecting to agent: No such file or directory

rose host-select
[FAIL] No (default) hosts specified.

I checked my config file and the .profile file and they look fine.

Lucia

comment:3 Changed 3 months ago by ros

Hi Lucia,

Please remove the SSH environment file:

rm ~/.ssh/environment.pumatest.nerc.ac.uk

Then log out of PUMATest and back in again. You should then see a message similar to:

Initialising new SSH agent…

Then run ssh-add, type in your passphrase and then ssh login.archer.ac.uk.
You should be logged onto ARCHER without prompt for password or passphrase.

Once you can log onto archer, try running rose host-select archer and hopefully it should connect to an ARCHER login node.

Cheers,
Ros.

comment:4 Changed 3 months ago by luciad

Thank you Ros,

That solved the problem.

Lucia

comment:5 Changed 3 months ago by grenville

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.