Opened 5 months ago

Closed 3 months ago

#3224 closed help (answered)

pptransfer from work to Jasmin

Reported by: mvguarino Owned by: um_support
Component: UM Model Keywords:
Cc: Platform:
UM Version:

Description

Hello,

I have been following the instructions (http://cms.ncas.ac.uk/wiki/Archer/Transition2020/PPTransfer) to change the workflow and move data from ARCHER to Jasmin following the RDF shutdown.

In my case, I had to change the host and remove the pre-script line in suite.rc rather than in archer.rc, suite id: u-bq802.

The transfer app fails with the following error :

/bin/sh: transfer.py: command not found
[FAIL] transfer.py <<'__STDIN__'
[FAIL] 
[FAIL] '__STDIN__' # return-code=127
Received signal ERR
2020-03-17T01:31:01Z CRITICAL - Task job script received signal ERR

Thanks,

Vittoria

Change History (12)

comment:1 Changed 5 months ago by ros

Hi Vittoria,

What is your username on JASMIN please?

My first guess, assuming you are modifying a run mid-way through and without being able to see stuff on JASMIN, is that the scripts haven't been built on JASMIN properly.

Cheers,
Ros.

comment:2 Changed 5 months ago by mvguarino

Hi Ros,

my JASMIN username is marino.

Thank you,

Vittoria

comment:3 Changed 5 months ago by ros

Can you change permissions so that we can see into your home directory please.

Cheers,
Ros.

comment:4 Changed 5 months ago by mvguarino

I have given rx permissions to the group (sorry I thought this was the default setting)

comment:5 Changed 5 months ago by ros

Hi Vittoria,

It looks like you have inserted/ran the fcm_make_pptransfer task but didn't do the same for the fcm_make2_pptransfer task.

Point 9 onwards in the "updating a running suite` instructions at the bottom of the page.

Regards,
Ros.

comment:6 Changed 5 months ago by mvguarino

Hi Ros,

Apologies! I interpreted instructions 8 - 12 as part of the same thread If nothing happens: You probably typed something incorrectly! Try again. and didn't pay attention to fcm_make2_ … -.- "

I have added the task and it is now submitted but waiting to start, it has been a while already. I'll update the ticket once I know it worked.

Thanks,
Vittoria

comment:7 Changed 5 months ago by mvguarino

Hi Ros,

The fcm_make2_pptransfer task got stuck similarly to this ticket (http://cms.ncas.ac.uk/ticket/3225), with the difference that in /cylc-run/suite-id/log/job/YYYYMMDDT0000Z the fcm_make2_pptransfer directory is not there.
The task however finished successfully, as when I tried to run PPTransfer this time the task ran.

However.. I now have the same connection problem between jasmin-xfer2 and archer for the pptranfer app, the task gets submitted but hangs there as 'submitted' while it is actually running in the background (I can see files are being transferred to Jasmin).
This causes a suite stalled problem.
The same happens for both my simulations u-bq802 and u-bk453.

Thanks for your help,

Vittoria

comment:8 Changed 3 months ago by grenville

Vittoria

Does this problem persist?

Grenville

comment:9 Changed 3 months ago by mvguarino

Hi Grenville,

It kept on existing unti I switched off the transfer app. So I guess it doesn't exist anymore :)
I transferred all my files using rsync afterwards.

Vittoria

comment:10 Changed 3 months ago by grenville

Hi Vittoria

I can't tranlate that - please resend

Grenville

comment:11 Changed 3 months ago by mvguarino

Mhhh not sure what happened… Anyway, this problem has been solved and the ticket can be closed.

PPtransfer kept on causing a suite stalled problem and I had to turn it off in order to keep on running my simulation smoothly. I then transferred my files using rsync from the terminal directly.

Vittoria

comment:12 Changed 3 months ago by grenville

  • Resolution set to answered
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.