Opened 5 months ago

Closed 3 months ago

Last modified 3 months ago

#3230 closed help (fixed)

MOSRS remote access

Reported by: Leighton_Regayre Owned by: um_support
Component: MOSRS Keywords:
Cc: Platform:
UM Version:

Description

Hello,

For the first time I am attempting to access pumatest remotely. I can ssh to pumatest, ARCHER and Jasmin with no problems. However, when my MOSRS password is requested I get the following error:

Met Office Science Repository Service password:
Subversion password cached
Traceback (most recent call last):

File "/usr/lib/python2.7/runpy.py", line 162, in _run_module_as_main

"main", fname, loader, pkg_name)

File "/usr/lib/python2.7/runpy.py", line 72, in _run_code

exec code in run_globals

File "/home/fcm/rose-2019.01.0/lib/python/rosie/ws_client_cli.py", line 25, in <module>

from rosie.ws_client import (

File "/home/fcm/rose-2019.01.0/lib/python/rosie/ws_client.py", line 36, in <module>

from rosie.ws_client_auth import RosieWSClientAuthManager

File "/home/fcm/rose-2019.01.0/lib/python/rosie/ws_client_auth.py", line 38, in <module>

import gtk

File "/usr/lib/python2.7/site-packages/gtk-2.0/gtk/init.py", line 64, in <module>

_init()

File "/usr/lib/python2.7/site-packages/gtk-2.0/gtk/init.py", line 52, in _init

_gtk.init_check()

RuntimeError?: could not open display
Error: Unable to access Rosie with given password

which looks to be caused by an inability of my terminal to open a necessary display. I guess this may be caused by my remote access set up. I am using *bitvise* software to access the Leeds server and am ssh'ing to pumatest from there using the command:

ssh -Y Leighton_Regayre@…

Thanks,

Leighton

Change History (3)

comment:1 Changed 5 months ago by Leighton_Regayre

Hello,

This problem was indeed caused by my choice of software for remote access, which was suppressing X11 behaviour regardless of settings.

Thanks,

Leighton

comment:2 Changed 3 months ago by ros

  • Resolution set to fixed
  • Status changed from new to closed

comment:3 Changed 3 months ago by ros

  • Component changed from UM Model to MOSRS
Note: See TracTickets for help on using tickets.