Opened 9 months ago

Closed 9 months ago

Last modified 9 months ago

#3288 closed help (fixed)

UKCA job submission: failed to connec to ARCHER

Reported by: emxin Owned by: um_support
Component: UM Model Keywords:
Cc: Platform: ARCHER
UM Version: 7.3

Description (last modified by ros)

Hi there,
I tried to submit UKCAj jobs using umui on PUMA, but failed to connect to ARCHER. I just recently updated my password on PUMA and ARCHER following the recent instruction given (ticket 3287). It seems I can log onto both PUMA and ARCHER without any problem.

I followed the instruction given (http://cms.ncas.ac.uk/blog/2020-05-26-) to fix the problem, but I don't think I fully understand it. for example:
1) I cannot find a file called config under ./ssh in PUMA. I am a bit confused, thus manually add a file 'config' with the following inform added:

Host login.archer.ac.uk
User <username>
IdentityFile ~/.ssh/<your private key to ARCHER>
ControlMaster auto
ControlPath /tmp/ssh-socket-%r@%h-%p
ControlPersist yes

Regarding the private key to ARCHER above, do I need to copy and past all the text shown in my id_rsa fiel?

2) I am not sure what I should do after I log on to ARCHER. I do not use Rose (but using old umui). please let me instructed.

cheers
Xin


AH

Change History (4)

comment:1 Changed 9 months ago by ros

Hi Xin,

Replace the <your private key to ARCHER> with the filename of your ARCHER private key (e.g. id_rsa_archer), which you need to have put in your ~/.ssh directory on PUMA if you haven't already.

Then simply login into archer with ssh login.archer.ac.uk. This opens a connection to ARCHR. Then submit your UMUI job. The job submission will use the connection to ARCHER that you have just opened.

Regards,
Ros.

comment:2 Changed 9 months ago by emxin

Thank Ros, it works now.

Xin

comment:3 Changed 9 months ago by ros

  • Resolution set to fixed
  • Status changed from new to closed

comment:4 Changed 9 months ago by ros

  • Description modified (diff)
Note: See TracTickets for help on using tickets.