Opened 9 months ago

Closed 9 months ago

Last modified 9 months ago

#3295 closed help (fixed)

Not clear why SSH not working after 2FA change

Reported by: markr Owned by: um_support
Component: PUMA Keywords: ssh, two factor authentication 2FA
Cc: Platform: PUMA
UM Version:

Description

Hello:
I tried to log in fro the leeds gaeway machine. I was able to add my new leeds2puma key bu then got rejected -I wonder is that because my puma session would try and launch an ssh-agent?
Here is what happened:
[earmgr@see-gw-01 ~]$ ssh-add .ssh/id_rsa_leeds2_puma
Enter passphrase for .ssh/id_rsa_leeds2_puma:
Identity added: .ssh/id_rsa_leeds2_puma (.ssh/id_rsa_leeds2_puma)
[earmgr@see-gw-01 ~]$ puma
* WARNING
This is a private computer facility. Access for any reason must be
specifically authorized by the owner

Permission denied (publickey).

Change History (9)

comment:1 Changed 9 months ago by markr

To be clear "puma" is an alias, doing long hand results in same:

[earmgr@see-gw-01 ~]$ ssh -Y markr@puma.nerc.ac.uk

***************************** WARNING ******************************
This is a private computer facility.  Access for any reason must be
specifically authorized by the owner
********************************************************************

Permission denied (publickey).

Last edited 9 months ago by markr (previous) (diff)

comment:2 Changed 9 months ago by andy

Hi Mark,

Can you try again and see if you get any further?

Cheers
Andy

comment:3 Changed 9 months ago by mtodt

Hi Andy

I've got the same problem trying to log in from my own machine.

Cheers
Markus

comment:4 Changed 9 months ago by markr

Hi Andy,
working from see-gw-01 now thanks

Mark

comment:5 Changed 9 months ago by markr

And from mobaxterm on win10 too thanks!

comment:6 Changed 9 months ago by mtodt

Yep, works for me now, too. Thanks, Andy!

Cheers
Markus

comment:7 Changed 9 months ago by markr

The system forced me to change my password again this morning.

I thought it might still be the one that you sent, but "old password" was what I had changed it to yesterday.
I have changed it and wwas able to log in again from mobaxterm.

comment:8 follow-up: Changed 9 months ago by andy

  • Resolution set to fixed
  • Status changed from new to closed

Hi Mark,

I've changed to password ageing for your account and the password shouldn't need resetting again.

Cheers
Andy

comment:9 in reply to: ↑ 8 Changed 9 months ago by markr

thanks!

Replying to andy:

Hi Mark,

I've changed to password ageing for your account and the password shouldn't need resetting again.

Cheers
Andy

Note: See TracTickets for help on using tickets.