#3305 closed help (fixed)

fcm

Reported by: zcui Owned by: um_support
Component: UM Model Keywords:
Cc: Platform:
UM Version:

Description

I tried fcm on ARCHER

fcm ls https://code.metoffice.gov.uk/svn/um/main/trunk/
returned
gpg-agent[3810]: Assuan processing failed: IPC read error
COPYRIGHT.txt
CodeOwners?.txt
admin/
bin/
fcm-make/
rose-meta/
rose-stem/
src/

But,
echo $SHLVL returned 3.

Change History (5)

comment:1 follow-up: Changed 10 months ago by dcase

Zhiqiang,

if you type fcm [a command] [a URL] and get a result then it looks as though things are working (the ls command gives the list directories, which you see). I know that you are also getting error messages, but I would ignore them if you are able to get the result that you wish. Also, the value of $SHLVL is 3, which is good.

If I were you, I would try to run the actual command that you are looking for (checking out code, for e.g.) and just ignore the errors.

If you aren't able to run the fcm command and get the result which you wish, then please reply to the ticket with the command and I'll see if I can recreate it. (If you could reply to this ticket, rather than make a new one, it's easier to follow our progress).

Thanks a lot,
Dave

comment:2 in reply to: ↑ 1 Changed 10 months ago by zcui

Replying to dcase:

Zhiqiang,

if you type fcm [a command] [a URL] and get a result then it looks as though things are working (the ls command gives the list directories, which you see). I know that you are also getting error messages, but I would ignore them if you are able to get the result that you wish. Also, the value of $SHLVL is 3, which is good.

If I were you, I would try to run the actual command that you are looking for (checking out code, for e.g.) and just ignore the errors.

If you aren't able to run the fcm command and get the result which you wish, then please reply to the ticket with the command and I'll see if I can recreate it. (If you could reply to this ticket, rather than make a new one, it's easier to follow our progress).

Thanks a lot,
Dave

Hi Dave

Thank you very much.

I can use fcm now. But I still got problem. Please see below

zcui@eslogin001:~> fcm bc rico fcm:monc.x_tr@vn0.9.0
gpg-agent[12218]: Assuan processing failed: IPC read error
gpg-agent[12218]: Assuan processing failed: IPC read error
gpg-agent[12218]: Assuan processing failed: IPC read error
gpg-agent[12218]: Assuan processing failed: IPC read error
[info] Source: https://code.metoffice.gov.uk/svn/monc/main/trunk@7765 (7765)
gpg-agent[12218]: Assuan processing failed: IPC read error
[info] vi: starting commit message editor…
Change summary:


A https://code.metoffice.gov.uk/svn/monc/main/branches/dev/zhcu/vn0.9.0_rico


Commit message is as follows:


test monc for rico
Created /main/branches/dev/zhcu/vn0.9.0_rico from /main/trunk@7765.


Create the branch?
Enter "y" or "n" (or just press <return> for "n") y
gpg-agent[12218]: Assuan processing failed: IPC read error
svn: E165001: Commit blocked by pre-commit hook (exit code 1) with output:
2020-06-17T13:43:58Z+ 7989-6bc by zhiqiangcui
A main/branches/dev/zhcu/
A main/branches/dev/zhcu/vn0.9.0_rico/
[INVALID BRANCH OWNER] A main/branches/dev/zhcu/vn0.9.0_rico/
[FAIL] svn copy —file /work/n02/n02/zcui/tmp/tmp.eslogin001.9849/ASBZOqG0bj —parents https://code.metoffice.gov.uk/svn/monc/main/trunk@7765 https://code.metoffice.gov.uk/svn/monc/main/branches/dev/zhcu/vn0.9.0_rico # rc=1

Thanks for your help.

Zhiqiang

comment:3 Changed 10 months ago by dcase

This is slightly strange, because it appears as though you can access the MOSRS repo', but you are making a branch creation in the name zhcu, not your MOSRS name.

Can you check your name in the ~/.subversion/servers file? You should have your username as your MOSRS username, not your ARCHER username.

Could you check this and try again if it's not username = zhiqiangcui

If it is, and this isn't the error, let me know.

Thanks

Last edited 10 months ago by dcase (previous) (diff)

comment:4 Changed 10 months ago by zcui

Dave has helped my solved the problem which was caused by repeated username in the subversion file.

comment:5 Changed 10 months ago by dcase

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.