#3316 closed help (fixed)

Error running standard suite from UM practical session document

Reported by: ecmaters Owned by: um_support
Component: UM Model Keywords:
Cc: Platform:
UM Version:

Description

Hello,

I'm trying to work through the NCAS Unified Model Introduction: Practical sessions (Rose/Cylc?) November 2019 document, and an error pops up when I try to run the suite in section 3.2 iii. Are the instructions in section 3.2 ii still correct (HPC account 'n02-training' and HPC_QUEUE reservation code 'R6585903') even though I'm not at the November 2019 training course? And/or does the problem lie elsewhere? I will attach an image of the error pop-up.

Kind regards,

Elena

Attachments (2)

error.png (276.7 KB) - added by ecmaters 10 months ago.
error2.png (327.3 KB) - added by ecmaters 10 months ago.

Download all attachments as: .zip

Change History (10)

Changed 10 months ago by ecmaters

comment:1 Changed 10 months ago by grenville

Elena

It's asking for a password but should not be - have you set up the ssh config file as described here http://cms.ncas.ac.uk/blog/2020-05-26-

You will need to use your own budget (n02-chem?) and use the regular ARCHER queues - the reseervations were valid only at the time we delivered the course

Grenville

comment:2 Changed 10 months ago by ecmaters

Hi Grenville,

Thanks for clarifying which budget and queue to use. As for the password - I've checked and yes the ssh config file is set up as described in the link. But I believe it always asks me for a password the first time I login to ARCHER from PUMA.

Elena

Changed 10 months ago by ecmaters

comment:3 Changed 10 months ago by ecmaters

When I tried again just now using the 'n02-chem' budget and 'short' queue (?), I no longer get the same error message pop up, but instead a new window pops up showing a task F1 and state submit-failed (see second image attached). Is this still related to the issue of it asking for a password to login from PUMA to ARCHER?

comment:4 Changed 10 months ago by grenville

please allow us read permission on your /home and /work spaces on archer

chmod -R g+rX /home/n02/n02/<username>
chmod -R g+rX /work/n02/n02/<username>

comment:5 Changed 10 months ago by ecmaters

Alright I've just done this

comment:6 Changed 10 months ago by grenville

In the suite.rc file change

batch system = at
to
batch system = background

Grenville

comment:7 Changed 10 months ago by ecmaters

Thank you - I think this has worked now, at least no error popped up and the window instead says 'running' or 'succeeded' and I see a job listed when I run 'qstat -u ecm63' in ARCHER.

comment:8 Changed 10 months ago by grenville

  • Resolution set to fixed
  • Status changed from new to closed

glad it's going (we should get rid of "at")

I'll close this ticket.

Note: See TracTickets for help on using tickets.