Opened 4 weeks ago

Last modified 4 weeks ago

#3320 new error

pptransfer failing for first month

Reported by: pmcguire Owned by: um_support
Component: UM Model Keywords: pptransfer, ARCHER
Cc: Platform: ARCHER
UM Version: 11.5

Description

Hi CMS-support
I am running suite u-bb937 on ARCHER, and the pptransfer app failed for the first month, complaining that the directory /work/n02/n02/pmcguire/archive/u-bv937/19880901T0000Z/ doesn't exist. The corresponding directories do exist for the next two months (October, November 1988).

I tried to create that directory, and then I tried retriggering the pptransfer app in the Cylc GUI. But the submission failed when I did that.

Also, I note that UM Version 11.5 is not available in the options below, so I chose UM Version 11.4.
Any suggestions?
Patrick McGuire

Change History (9)

comment:1 Changed 4 weeks ago by ros

Hi Patrick,

Looking at the postproc for that cycle there was nothing to archive. pptransfer should therefore decide there is nothing to transfer and finish. I will make a note to look at that. So just manually set the status of the pptransfer task to succeeded and let the suite carry on.

Cheers,
Ros.

Last edited 4 weeks ago by ros (previous) (diff)

comment:2 Changed 4 weeks ago by ros

  • UM Version changed from 11.4 to 11.5

comment:3 Changed 4 weeks ago by pmcguire

Hi Ros:
Thanks!
I did that.
But then I try to retrigger the pptransfer app for the next month (October 1988), but it also gets a submit-failed result.
Maybe I am doing something wrong?
Patrick

comment:4 Changed 4 weeks ago by ros

Hi Patrick,

If you look in the log/suite/log file you'll see a permission denied error logging into ARCHER. Check your connection to ARCHER. May just be you need to login into ARCHER to re-establish the master socket connection.

Cheers,
Ros.

comment:5 Changed 4 weeks ago by pmcguire

thanks!!!
Patrick

comment:6 Changed 4 weeks ago by pmcguire

For the 2FA on Archer & Puma, and running suites, is everything that I should know about it here?:
http://cms.ncas.ac.uk/wiki/Archer/Transition2020/PPTransfer

Is there anything else I need to know about it, for preventing my Puma→Archer connection from getting stale and causing the problem you found in the comment:4 comment above?: http://cms.ncas.ac.uk/ticket/3320#comment:4

Patrick

comment:7 Changed 4 weeks ago by ros

All the information on setting your connection to ARCHER after the change to 2FA for running any Rose/Cylc suite was in the email that Grenville sent out a few weeks ago. Have you got that one or do you want me to dig it out and resend?

Cheers,
Ros.

comment:8 Changed 4 weeks ago by ros

Just remembered it's on our website here: ARCHER 2FA Announcement

Cheers,
Ros.

Last edited 4 weeks ago by ros (previous) (diff)

comment:9 Changed 4 weeks ago by pmcguire

I think pptransfer is working now.
Thanks, Ros!

I added this step to the http://cms.ncas.ac.uk/wiki/Archer/Transition2020/PPTransfer page:

  1. If the passphrase doesn't work in the previous step, you may need to convert your OpenSSH-formatted ssh-key to a pem-formatted key, with a command like ssh-keygen -p -m pem -f <jasmin-key>, run on your own computer. This does the format conversion in place, so make sure you keep a backup of your original OpenSSH-formatted ssh-keys. Then copy those newly-formatted keys to espp1.

Patrick McGuire

Note: See TracTickets for help on using tickets.