Opened 6 months ago

Closed 5 months ago

#3354 closed help (answered)

Error submitting to Archer

Reported by: sallyaw Owned by: ros
Component: UM Model Keywords:
Cc: Platform: ARCHER
UM Version:

Description

I am trying to run a UM job for the first time and when submitting to ARCHER I get the following error which I don't understand:

/home1/z00/puma-access-route/bin/pumawrapper: line 80:
umui_runs/xovps-239153238/SUBMIT: No such file or directory

job is: xovps
username: sallyaw

Change History (12)

comment:1 Changed 6 months ago by ros

Hi Sally,

Can you cut and paste all the output to the job submission window that pops up when you click SUBMIT please. None of the job control files have been copied to ARCHER hence why it can't find the SUBMIT script. I'm hoping there is some error message or output before the error you posted above.

Cheers,
Ros.

comment:2 Changed 6 months ago by sallyaw

There is this above it:

qsub: script file:: No such file or directory
MAIN_SCR: Submit failed

comment:3 Changed 6 months ago by ros

Hi Sally,

Figured it out. The original ssh config instructions I sent assumed you would be running Rose/Cylc suites. The UMUI knows nothing about login7.archer.ac.uk so until the ARCHER wrapper is rolled out to all login nodes you will need to add the following workaround. In your ~/.ssh/config file make a slight change so it reads:

Host login.archer.ac.uk
Hostname login7.archer.ac.uk
User sallyaw
IdentityFile ~/.ssh/id_rsa_archerum
ForwardX11 no
ForwardX11Trusted no

Then in the UMUI job change the host name in window "User Info & Submit Method → Job Submission method → Host name" to be login.archer.ac.uk

Save, Process & Submit

Cheers,
Ros.

comment:4 Changed 6 months ago by ros

  • Owner changed from um_support to ros
  • Status changed from new to accepted

comment:5 Changed 6 months ago by sallyaw

Hi Ros,

I'm still getting the same error, I've made the changes and tried after logging out and back into PUMA.

Not sure if either of these are relevant to this issue but thought I'd raise them now.

I'm not sure what account to put in on the "User Info & Submit Method → General Details → Account Name" I was using n02 as this is what I could find on my ARCHER safe account and then n02-NCAS as one of my first emails said I was under the NCAS project. How do I find what to put here?

Another thing I'm not sure about is if my .profile file on ARCHER is correct? I copied the text from https://puma.nerc.ac.uk/trac/UM_TUTORIAL/wiki/UmTutorial/SettingUp

Finally if all of that looks okay I can try submitting one of the jobs from the training documents you sent me to see if that works?

Thanks for all the help!
Sally

comment:6 Changed 6 months ago by ros

Hi Sally,

The Account name is the budget that your ARCHER usage will be charged to. You are currently not a member of any ARCHER budget. Please ask your PI which account/project code to charge to. Then let me know and I will add you to that account.

This will not be stopping the submission a this stage.

Your .profile on ARCHER looks fine, other than you should change the UM version from 8.2 to 8.5.

You can try one of the training jobs but they all use the same submisison mechanism so shouldn't make any difference.

Can you also run on PUMA ssh login.archer.ac.uk. You should not be prompted for a password/passphrase and should get the following output:

ros@puma$ ssh login.archer.ac.uk
--------------------------------------------------------------------------------
This is a private computing facility. Access to this service is limited to those
who have been granted access by the operating service provider on behalf of the
contracting authority and use is restricted to the purposes for which access was
granted. All access and usage are governed by the terms and conditions of access
agreed to by all registered users and are thus subject to the provisions of the
Computer Misuse Act, 1990 under which unauthorised use is a criminal offence.

If you are not authorised to use this service you must disconnect immediately.
--------------------------------------------------------------------------------

PTY allocation request failed on channel 0
Comand rejected by policy. Not in authorised list 
Connection to login.archer.ac.uk closed.

If that doesn't shed any light and you see no error messages when you submit a suite in the terminal window where you ran the umui from or to the job submission window, I can only suggest we do a zoom screenshare to try and figure out what is happening.

Regards,
Ros.

comment:7 Changed 6 months ago by sallyaw

Okay will sort check with PI, however he is away this week so will have to wait on that one.

I get the following:

sallyaw@puma:/home/sallyaw> ssh login.archer.ac.uk
--------------------------------------------------------------------------------
This is a private computing facility. Access to this service is limited to those
who have been granted access by the operating service provider on behalf of the
contracting authority and use is restricted to the purposes for which access was
granted. All access and usage are governed by the terms and conditions of access
agreed to by all registered users and are thus subject to the provisions of the
Computer Misuse Act, 1990 under which unauthorised use is a criminal offence.

If you are not authorised to use this service you must disconnect immediately.
--------------------------------------------------------------------------------

PTY allocation request failed on channel 0
Comand rejected by policy. Not in authorised list
Connection to login7.archer.ac.uk closed.

The final line is different, referring to login7 not login, I have checked my ~/.shh/config file, which I think is correct:

Host login.archer.ac.uk
Hostname login7.archer.ac.uk
User sallyaw
IdentityFile ~/.ssh/id_rsa_archerum
ForwardX11 no
ForwardX11Trusted no

I am happy to do a call at some point, I am busy today 3-4pm and tomorrow 3pm onwards.

Thanks,
Sally

comment:8 Changed 6 months ago by ros

Hi Sally,

That's all fine - ssh response as expected.

I would try running one of the training jobs and see what that does.

I'm around tomorrow morning. Assuming the same happen's with the training job, how does 10:30am sound?

Cheers,
Ros.

comment:9 Changed 6 months ago by ros

Hi Sally,

I think I've managed to recreate your problem.

On ARCHER please run the following to create the umui_runs directory:

mkdir ~/umui_runs

This directory should be created automatically but I guess it's failing and the error is being swallowed by the UMUI somewhere.

Let me know if that makes a difference.

Cheers,
Ros.

comment:10 Changed 6 months ago by sallyaw

Hi Ros,

That has worked!

I'm now getting to the point where I get an error about not having the correct budget code to allocate the job to, so will have to wait to solve that until my PI get back.

Thanks for all the help!

Best,
Sally

comment:11 Changed 6 months ago by ros

Hi Sally,

Have you determined which ARCHER budget you will be using?

Regards,
Ros.

comment:12 Changed 5 months ago by ros

  • Resolution set to answered
  • Status changed from accepted to closed

Sally added to n02-ncas.

Note: See TracTickets for help on using tickets.