Opened 14 months ago

Last modified 14 months ago

#3361 new task

running the latest revision of the JULES/FLUXNET suite u-al752 on JASMIN

Reported by: kwilliams Owned by: jules_support
Component: JULES Keywords: JULES, FLUXNET
Cc: fo196883 Platform: JASMIN
UM Version:

Description

Hi Patrick

Could you try running the latest revision of the JULES/FLUXNET suite u-al752 on JASMIN?

Patrick

Change History (8)

comment:1 Changed 14 months ago by pmcguire

Hi Karina:
OK. I will try running the new version of the suite on JASMIN.
Patrick

comment:2 Changed 14 months ago by pmcguire

  • Cc fo196883 added

Hi Karina & Frederick
The u-al752 suite has been submitted and is running on CEDA JASMIN at the moment. I copied the vn1.3 data to JASMIN, too.

To get it past the compile stage on JASMIN, I had to switch from JULES 5.6 to JULES 5.8, since the group workspace path for jules and curl is hardwired for JASMIN in JULES5.6 trunk to the old GWS path, which has changed. I don't know if there are scientific or other changes to JULES since 5.6 which would change any computational output, but we'll see. Another alternative would be to take a branch of JULES 5.6, and change the jules group workspace path in there.

I updated the documentation at:
https://research.reading.ac.uk/landsurfaceprocesses/software-examples/tutorial-rose-cylc-jules-on-jasmin/

Patrick

comment:3 Changed 14 months ago by pmcguire

Great that it's submitted and is running!

If the output is the same as before (at or near the bit level) it sounds like it'd be very worthwhile to update u-al752/trunk to JULES 5.8.

I think that you creating a branch of 5.6 with the correct JASMIN paths is a good idea anyway, as it'll really help anyone that's still using that version (I imagine most people are still running some suites with previous versions of JULES - I know I am!). I did something similar when the library paths at the Met Office changed, and that branch ended up getting used a lot.

Cheers,
Karina

comment:4 Changed 14 months ago by pmcguire

Hi Karina & Frederick
The jules task succeeded for all the sites, but it failed in make_plots after making 43 out of 68 pages of plots. I will try to sort out sometime soon why it fails (error message below).
My 43 plots are on JASMIN at: /work/scratch-nopw/pmcguire/fluxnet/run18a
I will compare those plots to your v5.6 ones on MONSOON.
Patrick


ERROR MESSAGES:
It says there is a zero slice error:

File "/home/users/pmcguire/cylc-run/u-al752/bin/make_plots.py", line 133, in <module>

main()

File "/home/users/pmcguire/cylc-run/u-al752/bin/make_plots.py", line 129, in main

make_plots_for_jpeg()

File "/home/users/pmcguire/cylc-run/u-al752/bin/make_plots.py", line 122, in make_plots_for_jpeg

parallel=True

File "/home/users/pmcguire/cylc-run/u-al752/bin/fluxnet_evaluation.py", line 1504, in make_plots

parallel=parallel)

File "/home/users/pmcguire/cylc-run/u-al752/bin/parallelise.py", line 43, in wrap_map

res = pool.map(partial_func, func_arg)

File "/usr/lib/python2.7/multiprocessing/pool.py", line 227, in map

return self.map_async(func, iterable, chunksize).get()

File "/usr/lib/python2.7/multiprocessing/pool.py", line 528, in get

raise self._value

IndexError: Cannot index with zero length slice.

This error occurred during or after getting to this point in the log file:
GPP LBA_K83-JULES_vn5.8-presc0
reading /work/scratch-nopw/pmcguire/fluxnet/run18a/jules_output/LBA_K83-JULES_vn5.8-presc0.D*.nc

At first glance, that .nc file looks fine.

comment:5 Changed 14 months ago by pmcguire

Just a thought: check you're extracting the latest version of the post-processing code in
https://code.metoffice.gov.uk/trac/roses-u/browser/a/l/7/5/2/trunk/rose-suite.conf
i.e. 18106

Cheers,
Karina

comment:6 Changed 14 months ago by pmcguire

Hi Karina
Yes, I was using v18106.
Patrick

comment:7 Changed 14 months ago by pmcguire

Hi Patrick,

You've probably tried this already, but just in case: setting parallel=False in make_plots might make the error message more informative.

Cheers,
Karina

comment:8 Changed 14 months ago by pmcguire

Hi Karina
I have't tried that parallel=False yet. Thanks for the tip. I will try that next.
Patrick

Note: See TracTickets for help on using tickets.