Opened 7 months ago

Closed 4 months ago

#3379 closed error (answered)

Main run failed but spin up run succeed

Reported by: yaogao Owned by: jules_support
Component: JULES Keywords: JULES
Cc: Platform: JASMIN
UM Version:

Description

Hi,
I just could not think through this. The spin up run succeed, but the main run give me the error like below. [FATAL ERROR] map_from_land: Input data must be on land points. What could be the cause of this error?

Environment variables set for netCDF Fortran bindings in

/apps/libs/netCDF/intel14/fortran/4.2/

You will also need to link your code to a compatible netCDF C library in

/apps/libs/netCDF/intel14/4.3.2/

[WARN] file:ancillaries.nml: skip missing optional source: namelist:jules_rivers_props
[WARN] file:imogen.nml: skip missing optional source: namelist:imogen_anlg_vals_list
[WARN] file:urban.nml: skip missing optional source: namelist:jules_urban_switches
[WARN] file:ancillaries.nml: skip missing optional source: namelist:cable_progs
[WARN] file:urban.nml: skip missing optional source: namelist:jules_urban2t_param
[WARN] file:cable_soilparm.nml: skip missing optional source: namelist:cable_soilparm
[WARN] file:ancillaries.nml: skip missing optional source: namelist:jules_crop_props
[WARN] file:ancillaries.nml: skip missing optional source: namelist:jules_irrig
[WARN] file:crop_params.nml: skip missing optional source: namelist:jules_cropparm
[WARN] file:jules_deposition.nml: skip missing optional source: namelist:jules_deposition_species(:)
[WARN] file:urban.nml: skip missing optional source: namelist:urban_properties
[WARN] file:imogen.nml: skip missing optional source: namelist:imogen_run_list
[WARN] file:cable_surface_types.nml: skip missing optional source: namelist:cable_surface_types
[WARNING] WARN_JULES_TEMP_FIXES:
jules:#610 fix to the radiative roof coupling is not enabled: l_fix_moruses_roof_rad_coupling = .FALSE.
[WARNING] WARN_JULES_TEMP_FIXES:
Model run excludes a change from ticket um:#4581 as

l_fix_osa_chloro=.FALSE.
This will mean that chlorophyll used for the ocean albedo is
used in gm-3 when it should be mg m-3

[WARNING] init_ic: Provided variable 'gs' is not required, so will be ignored
[FATAL ERROR] map_from_land: Input data must be on land points
Image PC Routine Line Source
jules.exe 000000000049124B logging_mod_mp_wr 159 logging_mod.F90
jules.exe 0000000000542AFF model_interface_m 13764 model_interface_mod.F90
jules.exe 00000000004FD3DB model_interface_m 10261 model_interface_mod.F90
jules.exe 000000000062E5EC output_mod_mp_sam 789 output_mod.F90
jules.exe 0000000000409E28 MAIN 153 jules.F90
jules.exe 0000000000409CB6 Unknown Unknown Unknown
libc.so.6 000000332E61ED20 Unknown Unknown Unknown
jules.exe 0000000000409BA9 Unknown Unknown Unknown
MPI Application rank 0 exited before MPI_Finalize() with status 1
[FAIL] rose-jules-run <<'
STDIN'
[FAIL]
[FAIL] '
STDIN' # return-code=1
2020-09-22T13:17:53Z CRITICAL - failed/EXIT

Change History (5)

comment:1 Changed 7 months ago by pmcguire

Hi Yao
I am not sure how much I can help you, but I can try. First of all, what is the suite number for your Rose/Cylc suite? Secondly, can you change the permissions of your home directory and roses directory and cylc-run directory so that I can view your files?
Patrick

comment:2 Changed 7 months ago by yaogao

Hi Patrick,

I had the above problem when using JULES vn5.8_permafrost. After post this ticket, I just tried to switch to JULES vn5.8 for a test, and it gives output. So I guess the problem is maybe with some settings in vn5.8_permafrost.

Thanks for your help!
Yao

comment:3 Changed 6 months ago by pmcguire

Hi Yao:
Is it working better now?
Patrick

comment:4 Changed 6 months ago by yaogao

Hi Patrick,

Following the changes in the link to switch from LSM to SLURM that you sent in ticket #3376, Jules version 5.8 is working for me now on the correct machine with SLURM batch.

Thank you so much for your help!
Yao

comment:5 Changed 4 months ago by grenville

  • Resolution set to answered
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.