Opened 6 months ago

Closed 3 months ago

#3385 closed help (answered)

restart suite failed

Reported by: znjs2 Owned by: um_support
Component: UM Model Keywords:
Cc: Platform: Monsoon2
UM Version: 11.2

Description

Hi there,

I've tried to restart a suite which was previously running for 10 years and it's failed on the coupled task.

I've got the following in the job.err file:

[WARN] file:STASHC: skip missing optional source: namelist:exclude_package(:)
[WARN] file:ATMOSCNTL: skip missing optional source: namelist:jules_urban2t_param
[WARN] file:RECONA: skip missing optional source: namelist:trans(:)
[WARN] file:IDEALISE: skip missing optional source: namelist:idealised
[WARN] file:RECONA: skip missing optional source: namelist:ideal_free_tracer(:)
[WARN] file:IOSCNTL: skip missing optional source: namelist:lustre_control
[WARN] file:IOSCNTL: skip missing optional source: namelist:lustre_control_custom_files
[WARN] file:RECONA: skip missing optional source: namelist:recon_idealised
[WARN] file:SHARED: skip missing optional source: namelist:jules_urban_switches
[SUBPROCESS ERROR] <module 'error' from '/working/d04/zstanias/cylc-run/u-bw550/work/20250101T0000Z/coupled/error.py'>
Traceback (most recent call last):

File "./link_drivers", line 205, in <module>

envinsts, launchcmds = _run_drivers(common_envars, mode)

File "./link_drivers", line 69, in _run_drivers

mode)

File "/working/d04/zstanias/cylc-run/u-bw550/work/20250101T0000Z/coupled/nemo_driver.py", line 699, in run_driver

exe_envar = _setup_executable(common_envar)

File "/working/d04/zstanias/cylc-run/u-bw550/work/20250101T0000Z/coupled/nemo_driver.py", line 359, in _setup_executable

nemo_first_step = int(re.findall(r'.+=(.+),', first_step_val)[0])

IndexError?: list index out of range
[FAIL] run_model # return-code=1
2020-09-30T09:06:05Z CRITICAL - failed/EXIT

I initially restarted it after 1 year and it worked fine so am not sure where it's going wrong. The share/data/History_Data directory has the expected outputs from the end of the previous run.

I would appreciate your help,

Thanks,
Zosia

Change History (3)

comment:1 Changed 6 months ago by grenville

Zosia

I am not clear what you mean by:

I initially restarted it after 1 year and it worked fine so am not sure where it's going wrong. The share/data/History_Data directory has the expected outputs from the end of the previous run.

What cylce did your successful restart start from?

Grenville

comment:2 Changed 6 months ago by grenville

Zosia

Try deleting /working/d04/zstanias/cylc-run/u-bw550/work/20250101T0000Z, then restart the suite.

Grenville

comment:3 Changed 3 months ago by ros

  • Resolution set to answered
  • Status changed from new to closed

Closed due to lack of activity.

Note: See TracTickets for help on using tickets.