Opened 5 months ago

Closed 4 months ago

#3389 closed help (answered)

ssh PUMA to ARCHER not working

Reported by: sallyaw Owned by: ros
Component: SSH Keywords: puma, archer, ssh
Cc: Platform: PUMA
UM Version:

Description

When I have tried to submit jobs to ARCHER today I have been getting a number of errors related to ssh-ing onto ARCHER.
In one case I am getting the following error in my
~/um/um_extracts/xovps/baserepos/UMATMOS/ext.out
file.

Permission denied (publickey).
# Time taken:            1 s=> ssh -n -oBatchMode=yes login.archer.ac.uk mkdir -p /work/n02/n02/sallyaw/um/xovps/baserepos/UMATMOS/cfg
[FAIL] ssh -n -oBatchMode=yes login.archer.ac.uk mkdir -p /work/n02/n02/sallyaw/um/xovps/baserepos/UMATMOS/cfg failed (255) at /home/fcm/fcm-2017.10.0/bin/../lib/FCM1/Dest.pm line 755.

When submitting other UM jobs that have previously been successfully submitted they failed to submit.

I tried to re-connect my ssh-key and was getting an error when I tried to use ssh-add but followed the instructions on here http://cms.ncas.ac.uk/ticket/3380 and managed to re-add my key however I am unable to ssh from PUMA to ARCHER :

sallyaw@puma:/home/sallyaw> ssh-add .ssh/id_rsa_archerum
Enter passphrase for .ssh/id_rsa_archerum:
Identity added: .ssh/id_rsa_archerum (.ssh/id_rsa_archerum)
sallyaw@puma:/home/sallyaw> ssh sallyaw@login.archer.ac.uk
--------------------------------------------------------------------------------
This is a private computing facility. Access to this service is limited to those
who have been granted access by the operating service provider on behalf of the
contracting authority and use is restricted to the purposes for which access was
granted. All access and usage are governed by the terms and conditions of access
agreed to by all registered users and are thus subject to the provisions of the
Computer Misuse Act, 1990 under which unauthorised use is a criminal offence.

If you are not authorised to use this service you must disconnect immediately.
--------------------------------------------------------------------------------

PTY allocation request failed on channel 0
Comand rejected by policy. Not in authorised list
Connection to login7.archer.ac.uk closed.

Change History (2)

comment:1 Changed 5 months ago by ros

  • Owner changed from um_support to ros
  • Status changed from new to accepted

Hi Sally,

You have done the correct things, your ssh-agent is now setup correctly and the response from ARCHER is correct. It is not possible to login to ARCHER interactively from PUMA.

Submit your job to ARCHER and you should find it will connect to ARCHER ok.

Cheers,
Ros.

comment:2 Changed 4 months ago by ros

  • Resolution set to answered
  • Status changed from accepted to closed

I assume this is now working as expected.
Closing ticket.

Note: See TracTickets for help on using tickets.