Opened 4 months ago

Closed 4 months ago

#3404 closed help (answered)

Removing suite metadata for development work

Reported by: LesleyGray Owned by: ros
Component: UM Model Keywords: suite metadata
Cc: Platform: NEXCS
UM Version: 10.7

Description

I'm trying to run a copy of the CMIP6 piControl at N96 on Monsoon and Martin Andrews has advised me to use suite u-ar930
( https://code.metoffice.gov.uk/trac/roses-u/log/a/r/9/3/0 ).

I've made a copy of it (u-by590) but am having trouble getting past the validate suite (where it validates the suite metadata). The error message is reproduced below.

  1. I'm not sure what I should use as the 'Rose project'. I've tried leaving it as u-cmip6 (when it fails) but I've noticed that some other users who have copied this suite have used a different project e.g. u-ukca. Am I OK to continue with u-cmip6? (my runs are not contributing directly to the cmip6 project, they're helping to diagnose cmip6 results by doing some sensitivity expts).
  1. In the suite info notes there is a warning that for non-production runs using this suite then the metadata need to be removed using a remove_cmip6_metadata.py script but if I go to try and pick up this script from the code.metoffice.gov.uk/trac/ukcmip6/wiki I don't have permission to access the python code (the documentation is also not very helpful for people working outside of the Met Office e.g. says I may need to amend path to pick up the right python version, doesn't say which sub-directory I need to run it in).
  1. The error message says to check whether the controlled vocab file is correct, and the trac doc notes that the cv files have been updated, so I tried changing 3.2.5 to 6.2.0.5 but this didn't make any difference. (I noticed that Ros has a copy of this suite with 6.2.0.5 in it, but wasn't sure whether it was a good idea to try copying her suite in case there were other changes to it that I didn't need).

Apologies if I've overlooked something, but I hope you can help get me going…..

thanks
Lesley

Error message:


File "/home/d03/lgray/cylc-run/u-by590/bin/validate_suite_info.py", line 271, in <module>

main()

File "/home/d03/lgray/cylc-run/u-by590/bin/validate_suite_info.py", line 247, in main

cv_experiment_id = get_cv('experiment_id', revision=cv_revision)

File "/home/d03/lgray/cylc-run/u-by590/bin/validate_suite_info.py", line 215, in get_cv

raise Exception(msg)

Exception: Retrieval of controlled vocabulary failed. Please check carefully that the section ("experiment_id") and revision ("3.2.5") are b
oth valid.
command: curl -s -f https://raw.githubusercontent.com/WCRP-CMIP/CMIP6_CVs/3.2.5/CMIP6_experiment_id.json
return code: 22
[FAIL] python2.7 $CYLC_SUITE_RUN_DIR/bin/validate_suite_info.py $CYLC_SUITE_RUN_DIR <<'STDIN'
[FAIL]
[FAIL] 'STDIN' # return-code=1
2020-10-19T16:02:57Z CRITICAL - failed/EXIT

Change History (3)

comment:1 Changed 4 months ago by ros

  • Owner changed from um_support to ros
  • Status changed from new to accepted

Hi Lesley,

1) You can set the Rose project to be whatever you like it's just metadata to help you describe the suite.

2) The easiest thing to stop the validate_suite_info task running is just to edit the suite.rc file and remove the validate_suite_info task from the cylc graph.

In the suite.rc remove the following line from the graph:

{{ 'validate_suite_info => install_ancil' + ( ' & fcm_make2_pp' if POSTPROC else '') + (' & ' + FCMUM_LAST if BUILD_UM else '') + (' & fcm_make2_ocean' if BUILD_OCEAN else '') + (' & recon' if RECON else '') }}

The suite should then run ok.

Hope that helps.
Cheers,
Ros.

comment:2 Changed 4 months ago by ros

Hi Lesley,

If you wanted to run the script to strip out all the metadata you can download it by checking out the suite u-an000

rhatcher@xcs-c$ rosie co u-an000
rhatcher@xcs-c$ cd u-an000/bin

Edit the remove_cmip6_metadata.py to set ROSE_PYTHONPATH = '/home/d04/fcm/rose/lib/python'

Then run:

rhatcher@xcs-c$ ./remove_cmip6_metadata.py ~/roses/u-by590/rose-suite.info

Cheers,
Ros.

Last edited 4 months ago by ros (previous) (diff)

comment:3 Changed 4 months ago by ros

  • Resolution set to answered
  • Status changed from accepted to closed

Hi Lesley,

I assume you got this working and so will close this ticket.
Let me know if now.

Regards,
Ros.

Note: See TracTickets for help on using tickets.