Opened 4 months ago

Closed 3 months ago

#3413 closed help (answered)

help with JULES on JASMIN

Reported by: shyland Owned by: jules_support
Component: JULES Keywords: JULES, JASMIN
Cc: Platform: JASMIN
UM Version:

Description

I am a PhD student at the University of Exeter, who is also working with some members within the Met Office, and I am planning to run some global simulations on JULES via JASMIN. I have run into a couple of issues and I wish to ask the CMS helpdesk for some advice and guidance on them. I would like to request an account in order to do so.

Many thanks in advance for any help on this matter!!

Kind regards,

Sian

Attachments (2)

Diagnostic_setup.docx (416.7 KB) - added by pmcguire 4 months ago.
f9e496e4-c5b4-409a-b293-1299f390cb9a.jpeg (34.9 KB) - added by pmcguire 4 months ago.

Download all attachments as: .zip

Change History (11)

comment:1 Changed 4 months ago by pmcguire

Hi Sian:
We can get a CMS Helpdesk account created for you. I will request that. What questions do you have about JULES? You can write them here, while we wait for that account to be created.
Patrick McGuire

Changed 4 months ago by pmcguire

Changed 4 months ago by pmcguire

comment:2 Changed 4 months ago by pmcguire

Hi Patrick,

I have a few questions:

  1. I am preparing to set up a global run on JULES via JASMIN and am trying to look at the diagnostic set up of a suite in order to give me a little explanation of the different settings that can be applied. Fiona O’Connor (at the Met Office) tried helping me by sending a step-by-step guide (that I have attached below). However, I was faced with an issue in which I can see the ‘um’ and ’namelist’ tabs, but there doesn’t seem to be the subsequent ‘model input and output’ tab, i.e. I have been unable to complete step 3 of the helpsheet (I have also attached a screenshot of how my 'namelist tab' looks). Fiona and I had a meeting to try and sort this problem out but we discovered that the diagnostic set up differs between our identical checked out suites - she thinks it may be due to her running JULES on MONSOON and me using JULES on JASMIN. How do I check out a suite and view the diagnostic set up of it on JASMIN?
  1. a. I have also checked out a suite that runs global simulations (u-bw418) and in the rose-app.conf file it has the line ‘meta=jules-standalone/vn5.4’. However, when opening the suite in rose edit, I get the error “cannot find metadata for jules-standalone/vn5.4”. What does this mean and how can I go about rectifying it?
  1. b. I tried running this same suite to see what it does fully however it failed and I’m now stuck trying to shutdown the suite: I’ve tried both ‘rose suite-shutdown — — now’ and ‘rose suite-shutdown —name=u-bw418’ which have worked in the past, but now I am being greeted by the error "Cannot connect: https://jasmin-cylc.ceda.ac.uk:43064/set_stop_cleanly?kill_active_tasks=False: ('Connection aborted.', gaierror(-2, 'Name or service not known’)) [FAIL] cylc shutdown u-bw418 —force # return-code=1”. How can I kill the suite?

Many thanks in advance for any help on these matters!!

Kind regards,

Sian

comment:3 Changed 4 months ago by pmcguire

Hi Sian:
The instructions and screenshot you give are for a UM suite. Not a standalone JULES suite. I wasn't aware that a UM suite can be run as a standalone JULES suite, somehow.

I see that your suite u-bw418 is a standalone JULES suite. JULES doesn't use STASH, as far as I know right now. But you can see the output streams in the the jules_output_profile section with rose edit.

You can get started with running JULES on JASMIN with the tutorials at the University of Reading website:
https://research.reading.ac.uk/landsurfaceprocesses/software-examples/
It's probably best to start with the JULES/FLUXNET on JASMIN tutorial:
https://research.reading.ac.uk/landsurfaceprocesses/software-examples/tutorial-rose-cylc-jules-on-jasmin/
But there are also global gridded JULES on JASMIN tutorials on there.

Are you logged in to the cylc.jasmin server when you are running things? The jasmin-cylc.ceda server was removed around the same time that the JASMIN batch processing was converted to SLURM.

Patrick

comment:4 Changed 4 months ago by shyland

Hi Patrick,

Okay, thank you for those links - I shall go away and check them out!!

When running the suite and trying to kill it, I was logged into a new server cylc1.jasmin. I did log into the old server jasmin-cylc to try and end the suite on there but - as you said - that server has now been removed, so that attempt was also unsuccessful as I was unable to even connect to it. I just tried logging in and killing the suite via cylc.jasmin but I was greeted with the same error as before.

Many thanks,
Sian

comment:5 follow-up: Changed 4 months ago by pmcguire

Hi Sian:
About killing the suite since the original server has been removed, probably the best thing to do first is to contact support @ jasmin.ac.uk, and ask them. If that doesn't work, you can ask again here, and maybe I can try to help you figure it out.
Patrick

comment:6 Changed 4 months ago by pmcguire

Hi Sian:
But if you can't wait for killing the original suite, you can make a copy of the suite with a different name, withrosie copy u-bw418, for example, and try running the new suite.
Patrick

comment:7 in reply to: ↑ 5 Changed 4 months ago by shyland

Replying to pmcguire:

Hi Sian:
About killing the suite since the original server has been removed, probably the best thing to do first is to contact support @ jasmin.ac.uk, and ask them. If that doesn't work, you can ask again here, and maybe I can try to help you figure it out.
Patrick

Hi Patrick,

I thought I'd update you with what the JASMIN helpdesk said about the matter. They said: "It is not possible to kill a rose suite that was launched from the old cylc server using the new cylc server. The two cylc servers old and new are isolated. All processes on the old cylc server should have been killed after the server was switched off."

I haven't made any changes to the copy of the suite I checked out that I wish to particularly save. I was only running u-bw418 to get a better idea of what the suite did and see the visuals it produced before adapting it for my own research. So am I able to just delete my copy of this suite? Would that the kill the suite that is still running? Or is there a standard procedure for dealing with this?

Many thanks,
Sian

comment:8 Changed 4 months ago by grenville

Sian

To kill a running suite, see http://cms.ncas.ac.uk/wiki/UmTraining/November2019, Practical exercises, section 10.6 Problems shutting down suites.

Grenville

comment:9 Changed 3 months ago by grenville

  • Resolution set to answered
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.