Opened 5 months ago

Closed 5 months ago

#3421 closed help (answered)

Jasmin access from PumaTest

Reported by: luciana Owned by: um_support
Component: Rose/Cylc Keywords: Cylc, PumaTest
Cc: Platform: Other
UM Version:

Description

Hello.

Today I got access to PumaTest?, but I cannot access Jasmin from it. I'm getting an error with the passphrase. I checked online and it seems sometimes this happens. There is a small chance I just forgot the passphrase, but it's really small.

I've tried to connect to login1.jasmin.ac.uk, like I'm used to doing from Puma, and I've also tried to add the ssh key directly:

—-
ssh-add ~/.ssh/id_rsa_jasmin
—-

No success.

I also tried to run a suite to test remote access (cylc-examples/remote/minimal). I was not confident that it would work because I cannot even access the machine, but I've tried anyway. Then I got tons of warnings and an error.

—-

cylc val test

WARNING - deprecated items were automatically upgraded in 'user config':
WARNING - * (6.11.0) [state dump rolling archive length] - DELETED (OBSOLETE)
WARNING - * (7.0.0) [pyro][base port] - DELETED (OBSOLETE)
WARNING - * (7.0.0) [pyro][maximum number of ports] → [communication][maximum number of ports] - DELETED (OBSOLETE)
WARNING - * (7.0.0) [pyro][ports directory] - DELETED (OBSOLETE)
WARNING - * (7.0.0) [pyro] - DELETED (OBSOLETE)
WARNING - * (7.0.0) [authentication][hashes] - DELETED (OBSOLETE)
WARNING - * (7.0.0) [authentication][scan hash] - DELETED (OBSOLETE)
WARNING - * (7.0.0) [execution polling intervals] → [hosts][localhost][execution polling intervals] - value unchanged
WARNING - * (7.0.0) [submission polling intervals] → [hosts][localhost][submission polling intervals] - value unchanged
WARNING - * (7.3.1) [hosts][localhost][remote shell template] → [hosts][localhost][ssh command] - value unchanged
WARNING - * (7.3.1) [hosts][login\w*.archer.ac.uk][remote shell template] → [hosts][login\w*.archer.ac.uk][ssh command] - value unchanged
WARNING - * (7.3.1) [hosts][jasmin-xfer\d*.ceda.ac.uk][remote shell template] → [hosts][jasmin-xfer\d*.ceda.ac.uk][ssh command] - value unchanged
WARNING - * (7.3.1) [hosts][jasmin-sci\d*.ceda.ac.uk][remote shell template] → [hosts][jasmin-sci\d*.ceda.ac.uk][ssh command] - value unchanged
WARNING - * (7.3.1) [hosts][eddie3.ecdf.ed.ac.uk][remote shell template] → [hosts][eddie3.ecdf.ed.ac.uk][ssh command] - value unchanged
WARNING - * (7.3.1) [hosts][dtn02.rdf.ac.uk][remote shell template] → [hosts][dtn02.rdf.ac.uk][ssh command] - value unchanged
WARNING - * (7.3.1) [hosts][localhost][remote copy template] → [hosts][localhost][scp command] - value unchanged
WARNING - * (7.3.1) [hosts][login\w*.archer.ac.uk][remote copy template] → [hosts][login\w*.archer.ac.uk][scp command] - value unchanged
WARNING - * (7.3.1) [hosts][jasmin-xfer\d*.ceda.ac.uk][remote copy template] → [hosts][jasmin-xfer\d*.ceda.ac.uk][scp command] - value unchanged
WARNING - * (7.3.1) [hosts][jasmin-sci\d*.ceda.ac.uk][remote copy template] → [hosts][jasmin-sci\d*.ceda.ac.uk][scp command] - value unchanged
WARNING - * (7.3.1) [hosts][eddie3.ecdf.ed.ac.uk][remote copy template] → [hosts][eddie3.ecdf.ed.ac.uk][scp command] - value unchanged
WARNING - * (7.3.1) [hosts][dtn02.rdf.ac.uk][remote copy template] → [hosts][dtn02.rdf.ac.uk][scp command] - value unchanged
WARNING - * (7.6.0) [hosts][localhost][remote tail command template] - DELETED (OBSOLETE)
WARNING - * (7.6.0) [hosts][login\w*.archer.ac.uk][remote tail command template] - DELETED (OBSOLETE)
WARNING - * (7.6.0) [hosts][jasmin-xfer\d*.ceda.ac.uk][remote tail command template] - DELETED (OBSOLETE)
WARNING - * (7.6.0) [hosts][jasmin-sci\d*.ceda.ac.uk][remote tail command template] - DELETED (OBSOLETE)
WARNING - * (7.6.0) [hosts][eddie3.ecdf.ed.ac.uk][remote tail command template] - DELETED (OBSOLETE)
WARNING - * (7.6.0) [hosts][dtn02.rdf.ac.uk][remote tail command template] - DELETED (OBSOLETE)
WARNING - * (7.6.0) [hosts][localhost][local tail command template] → [hosts][localhost][tail command template] - value unchanged
WARNING - * (7.6.0) [hosts][login\w*.archer.ac.uk][local tail command template] → [hosts][login\w*.archer.ac.uk][tail command template] - value unchanged
WARNING - * (7.6.0) [hosts][jasmin-xfer\d*.ceda.ac.uk][local tail command template] → [hosts][jasmin-xfer\d*.ceda.ac.uk][tail command template] - value unchanged
WARNING - * (7.6.0) [hosts][jasmin-sci\d*.ceda.ac.uk][local tail command template] → [hosts][jasmin-sci\d*.ceda.ac.uk][tail command template] - value unchanged
WARNING - * (7.6.0) [hosts][eddie3.ecdf.ed.ac.uk][local tail command template] → [hosts][eddie3.ecdf.ed.ac.uk][tail command template] - value unchanged
WARNING - * (7.6.0) [hosts][dtn02.rdf.ac.uk][local tail command template] → [hosts][dtn02.rdf.ac.uk][tail command template] - value unchanged
WARNING - * (7.8.0) [suite host scanning] → [suite servers] - value unchanged
WARNING - * (7.8.0) [suite servers][hosts] → [suite servers][scan hosts] - value unchanged
WARNING - * (7.8.0) [suite logging][roll over at start-up] - DELETED (OBSOLETE)
ERROR - bad user config /home/luciana/.cylc/global.rc
Illegal item: [task events]reset timer
—-

I ran the suite I was running in Jasmin because they were supposed to work with Cylc 7.8.6. This is the message I get in Jasmin and the suite at least is valid there.

—-
[lucy@cylc1 minimal]$ cylc val test-remote
WARNING - deprecated items were automatically upgraded in 'suite definition':
WARNING - * (7.5.0) [title] → [meta][title] - value unchanged
WARNING - * (7.5.0) [description] → [meta][description] - value unchanged
Valid for cylc-7.8.6
—-

Now I just checked and in PumaTest? we have:

—-
$ cylc —version
7.8.1
—-

In Puma we have

—-
luciana@puma:/home/luciana> cylc —version
6.11.4
—-

and the suite is valid without a problem.

—-
luciana@puma:/home/luciana/puma/cylc-examples/remote/minimal> cylc val testtt Valid for cylc-6.11.4
—-

I'm getting stressed with so many different versions of Cylc. Then I stopped to think about you, the support, that has to deal with so many machines and different versions of different software. I don't envy your job.

I hope I can get out of this mess soon. But I'm learning a lot in the process, which is good. :)

Kind regards.

Luciana.

Change History (9)

comment:1 Changed 5 months ago by grenville

Luciana

The jasmin access problem needs to be fixed.
Please post here the ssh-add command and its output.

Grenville

comment:2 Changed 5 months ago by luciana

Dear Grenville.

As I mentioned before, the command works. The problem is that the passphrase is not being accepted.

—-
$ ssh-add ~/.ssh/id_rsa_jasmin
Enter passphrase for /home/luciana/.ssh/id_rsa_jasmin:
Bad passphrase, try again for /home/luciana/.ssh/id_rsa_jasmin:
—-

Kind regards.

Luciana.

comment:3 Changed 5 months ago by andy

Hi Luciana,

When your account was copied from puma to pumatest the ssh keys were also copied. Looking at your jasmin keys in your .ssh directory the permissions look fine but the creation times for the private and public keys are months apart. I would have thought that they would be the same as they are created at the same time. Check the ones that you use for login to jasmin normally from your laptop / institute computers and see if they match.

Cheers
Andy

comment:4 Changed 5 months ago by luciana

Hi Andy.

Currently, I only have access to Jasmin from puma. From Archer, sometimes works, sometimes not (I mentioned that in another ticket).

I don't have an explanation about the difference in the dates other than several trial-and-error attempts and little understanding of how the ssh actually works.

What would you suggest me to do?

Kind regards.

Luciana.

comment:5 Changed 5 months ago by ros

Hi Luciana,

In relation to logging into JASMIN from ARCHER: ARCHER do not allow outbound ssh connections from the login nodes - they will be terminated.

You could try logging into the ARCHER postprocessing nodes and see if you can reach JASMIN from there. Once on the ARCHER login node type ssh espp1 and enter your ARCHER password. If you can get from the pp node to JASMIN ok I would then do what Andy suggests and check that the key on ARCHER is the same as the one you are using on pumatest.

Regards,
Ros.

comment:6 Changed 5 months ago by luciana

Dear Ros.

The access from Archer to Jasmin is not important. I was just test the access to Jasmin from other sources as I was told to do.

The access to Jasmin from puma test is important and I still don't know how to do it. Should I start the whole ssh process to jasmin again?

I need this access because I need to test cylc's remote functionality.

Kind regards.

Luciana.

comment:7 Changed 5 months ago by grenville

Luciana

What happens on PUMA if you try to reload the JASMIN key into the agent (delete ~/.ssh/environment.puma, logout, login again, then ssh-add …)

If that works & you can login to jasmin, copy the jasmin key from PUMA to pumatest (maybe md5sum them) - if that still doesn't work, regenerate the jasmin key.

Grenville

comment:8 Changed 5 months ago by luciana

Hi Grenville.

So, for now, I've chosen one valid ssh-key pair, copied to Puma and Puma Test and now I can access Jasmin from both of them. Hopefully, that will be enough to make the remote access to work.

Thank you for your support.

Kind regards.

Luciana.

comment:9 Changed 5 months ago by ros

  • Resolution set to answered
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.