Opened 4 months ago

Closed 4 months ago

#3436 closed help (answered)

Reconfiguration error 'negative block started'

Reported by: anmcr Owned by: um_support
Component: UM Mesoscale Keywords: reconfiguration
Cc: Platform: Monsoon2
UM Version: 11.1

Description

Hi Helpdesk,

I am running the nested suite of the MetUM on Monsoon, model id u-bk818

The reconfiguration has unexpectedly failed with a 'negative block error', which I have not come across before. See below. There are no previous help desk tickets on this error.

I made the seaice ancillary which is related to the failure, but I can't see any issues with the file (at least using xconv). Also, the model has already run thousands of integrations (24 hr forecasts, to create a climatology) so I am unsure why it would fail now. In fact the following two forecasts (each starting 12 hrs later) have also failed with the same error.

I would be very grateful for any help.

Many thanks,

Andrew

IO: Open: /projects/polar/amworr/startdumps/AntarcticCORDEX/sic_sst/glm/19790101_00-19791231_12_sic_um_grid_glm_n768 on unit 13
replanca_rcf_replanca: UPDATE REQUIRED FOR FIELD 32 : SEA ICE DEPTH (MEAN OVER ICE) M
c_io ( 13):rbuff: negative block start generated for position -17173495808 (ouch!)

????????????????????????????????????????????????????????????????????????????????
???!!!???!!!???!!!???!!!???!!! ERROR ???!!!???!!!???!!!???!!!???!!!
? Error code: 1
? Error from routine: c_io_rbuffering_instantiate_block_for
? Error message: Negative block start generated
? Error from processor: 0
? Error number: 6
????????????????????????????????????????????????????????????????????????????????

Change History (4)

comment:1 Changed 4 months ago by anmcr

Hello again.
This might be for Jeff, as it involves 'xancil'.

My input file is: /projects/polar/amworr/startdumps/AntarcticCORDEX/sic_sst/glm/19790101_00-19791231_12_sic_um_grid_glm_n768.nc

I then using xancil to make a SIC ancillary: /projects/polar/amworr/startdumps/AntarcticCORDEX/sic_sst/glm/make_ancil.job

The resulting ancillary file is : /projects/polar/amworr/startdumps/AntarcticCORDEX/sic_sst/glm/19790101_00-19791231_12_sic_um_grid_glm_n768

Some of the fields are readable in xconv, especially the fields in early 1979. The files made for September onwards are unreadable using xconv, and are also the ones that the model is unable to reconfigure. The files from the input .nc file are all readable. So I think this suggests the error is with the xancil step.

I tried remaking the ancillaries, but the problem still exists.

I would be grateful for any advice/help.

Thanks,

Andrew

comment:2 Changed 4 months ago by jeff

Hi Andrew

Looking at make_ancil.job, it says you are using xancil version 0.50. This is quite an old version now and at version 0.57 there was a fix to allow creation of ancillary files > 16 GBytes. Your ancil file is ~30 GBytes so you need to use a later version. The latest version is 0.58 and can be found on monsoon here, ~jecole/linux_x86_64/bin/

Hopefully this will fix the problem.

Jeff.

comment:3 Changed 4 months ago by anmcr

Hi Jeff,

Thanks for your advice. I remade the ancillaries and the reconfiguration was fine, so your suggestion fixed the problem.

Please close this ticket.

Andrew

comment:4 Changed 4 months ago by jeff

  • Resolution set to answered
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.