Opened 6 weeks ago

Closed 6 days ago

Last modified 3 days ago

#3448 closed help (worksforme)

KPP regional suite bicgstab error

Reported by: EmmaHoward Owned by: um_support
Component: UM Model Keywords:
Cc: Platform:
UM Version:

Description

Hi Annette,

I’m having troubles with my 2km suite over on Archer (u-bz230), which is failing on the first atmosphere timestep, (the ocean seems to get to the second timestep okay). The suite uses new remap weights which Claudio kindly generated for me. The error I’m getting is NaNs? in the fast physics, so likely a problem with the input data. I can’t see any problems with the inputs, so my guess is that there’s an issue with the inputs coming over from oasis. Have you come across anything similar previously? Do you know if there's a way I can check the data being passed by oasis?

Atmosphere last output:


Fast physics sources for ENDGame from atmos_physics2:
min max average (non-bit reproducing (1=has NaN 0= no NaN)
s_u : -0.2288698072527861E+01 0.7880403393986910E+01 NaN 0.1000000000000000E+01
s_v : -0.1852446956739778E+02 0.5731066348730003E+01 NaN 0.1000000000000000E+01
s_w : 0.0000000000000000E+00 0.0000000000000000E+00 NaN 0.1000000000000000E+01
s_thetav : -0.1693080754457412E+01 0.7251417913115461E+01 NaN 0.1000000000000000E+01
s_m_v : -0.1765373194164627E-01 0.4381752801001577E-02 NaN 0.1000000000000000E+01
s_m_cl : -0.7659608561256719E-03 0.5782931988120135E-03 NaN 0.1000000000000000E+01
s_m_cf : -0.9147982894949173E-07 0.6305576308134313E-07 NaN 0.1000000000000000E+01
s_m_graup: 0.0000000000000000E+00 0.0000000000000000E+00 NaN 0.1000000000000000E+01
s_m_rain : -0.4860602684322754E-08 0.1721969215355467E-08 NaN 0.1000000000000000E+01


  • Linear solve for Helmholtz problem *
  • Outer Inner Iterations InitialError? *

????????????????????????????????????????????????????????????????????????????????
???!!!???!!!???!!!???!!!???!!! ERROR ???!!!???!!!???!!!???!!!???!!!
? Error code: 1
? Error from routine: EG_BICGSTAB
? Error message: NaNs? in error term in BiCGstab after 1 iterations
? This is a common point for the model to fail if it
? has ingested or developed NaNs? or infinities
? elsewhere in the code.
? See the following URL for more information:
? https://code.metoffice.gov.uk/trac/um/wiki/KnownUMFailurePoints
? Error from processor: 0
? Error number: 38
????????????????????????????????????????????????????????????????????????????????

KPP last output:

KPP: Trying to open flux file kpp_initfluxes.nc

Reading fluxes for time 304.020844, 304., 3600., 86400.

KPP: Reading fluxes from time point 1
KPP: Read taux
KPP: Read tauy
KPP: Read swf
KPP: Read lwf
KPP: Read lhf
KPP: Read shf
KPP: Read rain
KPP: Set snow to zero
KPP: Finished reading fluxes
KPP: Called fluxes
Reading climatological SST for time 304.5
SSTs are being read from position 14
KPP: SSTs have been read from position 14
KPP: Finished read_sstin
KPP: Called read_sstin, ntime = 1
KPP: Entering ocnstep loop, ntime= 1
Calling mean_output
In mean_output 25
Calling fluxes
KPP: Time for coupling in is 3600 seconds

Application 49289045 exit codes: 255
Application 49289045 exit signals: Killed

Best wishes,
Emma

Change History (3)

comment:1 Changed 4 weeks ago by EmmaHoward

I've traced this error to the ancillary files, which I've generated using the nesting suite. I'll try using CCI ancils rather than IGBP.

comment:2 Changed 6 days ago by EmmaHoward

  • Resolution set to worksforme
  • Status changed from new to closed

Using new ancils has resolved this problem.

comment:3 Changed 3 days ago by annette

Great thanks for letting us know.

Annette

Note: See TracTickets for help on using tickets.