Opened 4 weeks ago

Closed 4 weeks ago

#3453 closed help (fixed)

Trouble using mule on MONSooN2

Reported by: ajd Owned by: um_support
Component: Monsoon Keywords: mule, um_tools, perturb_theta
Cc: Platform: Monsoon2
UM Version:

Description

Hi CMS,

I'm trying to use the perturb_theta.py script (python2.7) to perturb an atmospheric start dump after the model blows up.

However, I'm having trouble loading mule/ um_tools.

If I go to type module load um_tools without anything else, then I get module not found.

If I do source $UMDIR/mule/modules/setup first, I can load um_tools and mule, but the python script then fails with a mule issue.

Do you know what could be going on, is this a python 3/python2.7 clash of some sort?

Any help would be greatly appreciated. Thanks!
Andrea

Change History (3)

comment:1 Changed 4 weeks ago by ros

Hi Andrea,

I don't think this is a python3/python2.7 issue. When I load um_tools I'm still in a python2.7 environment which should be fine for that script.

Oddly I can module load um_tools without the mule setup first, can't see I've done anything out of the ordinary in my profile.

What command are you running and what error message are you getting?

Cheers,
Ros.

comment:2 Changed 4 weeks ago by ajd

Hi Ros,

Thanks for getting back to me so quickly.

Weird, I just logged in again and managed to load um_tools straight away, also running the python script worked without any issues. I tried the exact same thing several times this morning and it didn't work, but it does now. No idea what happened, but the issue seems resolved!

Cheers,
Andrea

comment:3 Changed 4 weeks ago by ros

  • Keywords mule, um_tools, perturb_theta added
  • Resolution set to fixed
  • Status changed from new to closed

Hi Andrea,

Hmmm yes, that is weird. I'm glad it's working now though. I'll close this ticket, if you encounter it again feel free to reopen it.

Cheers,
Ros.

Note: See TracTickets for help on using tickets.