Opened 7 months ago

Last modified 7 months ago

#3492 new help

ARCHER2: easy aerosol; EM_FOPEN Error message: NetCDF error

Reported by: pmcguire Owned by: um_support
Component: ARCHER2 Keywords: em_fopen, ARCHER2. easy aerosol, ukca, NetCDF
Cc: mtodt Platform: ARCHER2
UM Version: 11.5

Description

Hi CMS support
When I run suite u-cc629 on ARCHER2 from PUMA, I get this error in the atmos_main app.

????????????????????????????????????????????????????????????????????????????????
???!!!???!!!???!!!???!!!???!!!       ERROR        ???!!!???!!!???!!!???!!!???!!!
?  Error code: 1
?  Error from routine: EM_FOPEN
?  Error message: NetCDF error
?  Error from processor: 0
?  Error number: 64
????????????????????????????????????????????????????????????????????????????????

I think this is an easyaerosol error (which I noted at the current end of ticket #3489; I think the paths are set right for all the easy aerosol files), since the routines which call em_fopen() are either easyaerosol or ukca, and we're not using ukca. But I might be mistaken about this.

The error number 64 might be

#define NC_ETRUNC       (-64)   // File likely truncated or possibly corrupted

listed here:
https://www.unidata.ucar.edu/software/netcdf/docs/nc-error-codes.html
But I am not sure about this either.

This suite previously worked on ARCHER. Not sure what has changed. Maybe one of the easyaerosol
files is corrupted or something?

Any suggestions as to what I could do to further diagnose and fix this?
Patrick

Change History (13)

comment:1 Changed 7 months ago by ros

Hi Patrick,

Please change your ARCHER2 /home and /work permissions so that we can see your files.

chmod -R g+rX /home/n02/n02/<your-username>
chmod -R g+rX /work/n02/n02/<your-username>

Cheer,
Ros.

comment:2 Changed 7 months ago by pmcguire

Hi Ros,
Thanks!
I changed the permissions.
Patrick

comment:3 Changed 7 months ago by ros

Hi Patrick,

Error in EM_FOPEN: No such file or directory - /work/y07/shared/umshared/highresmip/ancil/easyaerosol/1949-2015/n216e/easy_extinction_sw_PI-MACv2-SP-CMIP6-Volc_1949-2015_v2_N216e_AW_1949-2015.nc

Cheers,
Ros.

comment:4 Changed 7 months ago by pmcguire

Thanks Ros:
Your error message is much more informative than my error message was. How did you get that message?

On PUMA or ARCHER2, when I do a grep -r PI-MACv2 ~pmcguire/cylc-run/u-cc629/, I don't see that message anywhere.
And on PUMA, when I do grep -r PI-MACv2 ~ros/cylc-run/u-cc629-patrick/, I also don't see that message.

The suite has the cmip6_aerosols opt flag enabled, so the easyaerosol_files(1) variable from the standard settings 'easy_extinction_sw_PI-MACv2-SP-CMIP6-Volc_1949-2015_v2_N216e_AW_1949-2015.nc' should be overwritten by the value of
'volc_aer_extinction_sw.nc'. So I don't know why your version is trying to open up the original file.

Patrick

comment:5 Changed 7 months ago by ros

Hi Patrick,

I didn't get as far as running your suite; I found the error message in your directory:

/work/n02/n02/pmcguire/cylc-run/u-cc629/work/19880901T0000Z/atmos_main/pe_output/cc629.fort6.pe0000

Regards,
Ros.

comment:6 Changed 7 months ago by pmcguire

Hi Ros:
Thanks for finding that!
I didn't know that the job.err and job.out log files didn't have such messages included.
That is a much better error message than what was in job.err.
Patrick

comment:7 Changed 7 months ago by ros

Hi Patrick,

At older UM versions it used to cat the pe0 output file into the job.out file. In newer versions it doesn't, which, to be honest, is a pain in butt!! :-D

Cheers,
Ros.

comment:8 Changed 7 months ago by pmcguire

Hi Ros & Markus:
I just found that the cmip6_aerosols opt file had [namelist:easy_aerosol] instead of [namelist:easyaerosol]. That's probably why the settings were not getting overwritten properly for that cmip6_aerosols opt that we're using.
Patrick

comment:9 Changed 7 months ago by mtodt

Hi Patrick

Yes, that's why I said I updated the paths in both of them on MONSOON, because I wasn't sure which one would get used (or both).

Cheers
Markus

comment:10 Changed 7 months ago by pmcguire

Hi Markus:
The one that should be used in an ideal world is the cmip6_aerosols one, right?
Patrick

comment:11 Changed 7 months ago by mtodt

Yeah, I agree. It's an optional flag, so that addition must have been deliberate. However, I just looked up my old tickets and when Willie initially set up the suite on ARCHER with me, the files he needed to transfer from MONSOON were those used in namelist easyaerosol under app/um/rose-app.conf. I don't quite know what to make of that.

comment:12 Changed 7 months ago by pmcguire

Thanks, Markus,
So this means that since the suite previously used cmip6_aerosols as the opt flag, and there was previously a typo with an extra underscore in there with [namelist:easy_aerosol], that the suite was not using those cmip6_aerosols easy_aerosol settings in the past. Do you concur with that?

And this furthermore means that if I want to do a 35-year continuation run of a previous 20.5-year run with this suite, then I should use the default settings without the cmip6_aerosols easy_aerosol settings?
Patrick

comment:13 Changed 7 months ago by mtodt

I think that would make sense, yes. I can't say whether the ancillary files set in the optional configuration file aren't used, though. I suppose that seems sensible, but I find it hard to believe that no-one has found, or had troubles with, the typo yet.

Another question altogether is whether the 2 sets of easyaerosol files differ over their mutual time period.

Note: See TracTickets for help on using tickets.