Opened 10 days ago

Last modified 10 days ago

#3507 new help

mosrs authentication fails when running a rose suite

Reported by: katieblackford Owned by: um_support
Component: MOSRS Keywords: JULES, JASMIN, MOSRS, svn
Cc: Platform: JASMIN
UM Version:

Description

Hi,

I am trying to run a JULES suite on JASMIN. However, when I try to run the suite I get the following error:
cpu-bind=MASK - host091, task 0 0 [32084]: mask 0x20 set
[FAIL] config-file=/work/scratch-pw/katie_b1/cylc-run/u-cc320/work/19400101T0000+01/fcm_make/fcm-make.cfg:2
[FAIL] config-file= - https://code.metoffice.gov.uk/svn/jules/main/trunk/etc/fcm-make/make.cfg
[FAIL] https://code.metoffice.gov.uk/svn/jules/main/trunk/etc/fcm-make/make.cfg: cannot load config file
[FAIL] https://code.metoffice.gov.uk/svn/jules/main/trunk/etc/fcm-make/make.cfg: not found
[FAIL] svn: E215004: Authentication failed and interactive prompting is disabled; see the —force-interactive option
[FAIL] svn: E215004: Unable to connect to a repository at URL 'https://code.metoffice.gov.uk/svn/jules/main/trunk/etc/fcm-make/make.cfg'
[FAIL] svn: E215004: No more credentials or we tried too many times.
[FAIL] Authentication failed

[FAIL] fcm make -f /work/scratch-pw/katie_b1/cylc-run/u-cc320/work/19400101T0000+01/fcm_make/fcm-make.cfg -C /home/users/katie_b1/cylc-run/u-cc320/share/fcm_make -j 4 # return-code=1
2021-04-02T17:26:54+01:00 CRITICAL - failed/EXIT

I believe I have cached my mosrs password correctly. When I initially set this up I followed the instructions here: https://code.metoffice.gov.uk/trac/jules/wiki/RoseJULESonJASMIN. I have no problems logging in directly to cylc1 and when I do this I get messages to say "subversion pasword cached" and "Rosie password cached", so I don't understand why I am getting this error. I also haven't had this problem in running other suites, I only get it with this one.

Let me know if there's anything I may have missed in caching my mosrs password, or any suggestions as to why this may be happening.

Thanks,
Katie

Change History (7)

comment:1 Changed 10 days ago by ros

Hi Katie,

When you run

fcm ls https://code.metoffice.gov.uk/svn/jules/main/trunk/etc/fcm-make/make.cfg

on the cylc1 command line does it list the file ok or ask for authentication?

Can you also give us read access to your home directory please.

chmod -R g+rX /home/users/katie_b1

Cheers,
Ros

comment:2 Changed 10 days ago by katieblackford

Hi Ros,

When I run that command it lists the make.cfg file.
I believe I have also now given you read access to my home directory.

Thanks,
Katie

comment:3 Changed 10 days ago by ros

Hi Katie,

What are the ids of the jobs that do work so we can compare?

Cheers,
Ros.

comment:4 Changed 10 days ago by katieblackford

Hi Ros,

Suites u-ca315 and u-cc481 both currently work.

Thanks,
Katie

comment:5 Changed 10 days ago by ros

Hi Katie,

u-cc320 is trying to run the fcm_make task in the par-single queue which won't work, as it can't access the cached credentials on cylc1.

Both your other suites are running the fcm_make task in the background. Try changing the batch system to background in the suite.rc file for this task.

Cheers,
Ros.

comment:6 Changed 10 days ago by katieblackford

Hi Ros,

Thanks, I'll give that a go now.

Thanks,
Katie

comment:7 Changed 10 days ago by katieblackford

Hi Ros,

I no longer get that error, thanks for your help!

Katie

Note: See TracTickets for help on using tickets.