Opened 11 years ago

Closed 11 years ago

#355 closed help (fixed)

Model crashes when orographic height is changed

Reported by: jsau Owned by: willie
Component: UM Model Keywords: orography, ancillary fields, RHS zero
Cc: Platform:
UM Version: 6.1

Description

I am trying to get a basic UM vn6.1 run (xemqa) with modified ancillary fields. But when it comes to modifying the orography field, the model nearly always crashes in a way that I fail to understand. Most of the times it crashes before completing the 1st time step and yields the message:

"RHS zero so GCR(2) not needed."

I thought maybe the way I smoothed the orography was too sharp and led to instability of the model Therefore I tried 3 very simple modifications:

1) orographic height (ht) = 50% of actual ht (/home/n02/n02/jsau/um/umui_out/xemqd000.xemqd.d09342.t135336.leave)

→ CRASHED, "NaN" values appear at the end of the .leave file

2) orographic height (ht) = 60% of actual ht (/home/n02/n02/jsau/um/umui_out/xemqd000.xemqd.d09342.t153825.leave)

→ CRASHED, but no "NaN" values at the end of the .leave file

3) orographic height (ht) = 70% of actual ht (/home/n02/n02/jsau/um/umui_out/xemqd000.xemqd.d09342.t160947.leave)

→ DID NOT CRASH

Could you please help me understand why this is so? Should I try to progressively remove the orography, smoothing it a bit, running the model for a month, smoothing it a bit more, etc., in order for the extrapolation to yield realistic values? Is there something wrong with the other orographic fields (although I tried to change these on non-crashing runs and this did not appear to make them crash) and if so, how should I modify them?

(You will find the ancillary fields on /home/n02/n02/jsau/work/ancil/vn6.1/n96_hadgem1/output. They are respectively called qrparm.orog.minus50pct, qrparm.orog.minus40pct and qrparm.orog.minus30pct.)

Thank you,
Jerome.

Change History (5)

comment:1 Changed 11 years ago by willie

  • Owner changed from um_support to willie
  • Status changed from new to accepted

Hi Jerome,

I am no expert in this area. However, there is a procedure for creating orographic ancillary files and it is described in UM Documentation Paper 74 (available on the NCAS-CMS web site). There is also an overview of the gravity wave drag scheme in section 2.1.8 of the UM User Guide. I hope this helps.

In order to make your files readable by others, you need to change to you home directory and do

chmod g+rx .

(note the full stop). You should also do this in your work directory.

Regards,

Willie

comment:2 Changed 11 years ago by jsau

I had chmod-ed the …/output and …/umui_out, I thought this was enough for you to read my files. Now I have chmod-ed the whole $HOME and $WORK directories.

I cannot find UM documentation paper 74, although I did find papers 70 (ancillary files specification) and 73 (ancillary files creation).

Thank you,
Jerome.

comment:3 Changed 11 years ago by willie

Hi Jerome,

You can find it under UM Documents (in the left panel of the CMS web page). Then click on Met Office Documents > UM version 5.5 > Technical. It's the sixth one down.

Thanks for chmod'ing the directories - this is useful for providing future help.

Regards,

Willie

comment:4 Changed 11 years ago by jsau

OK, I found the cause of my problems: I had not seen the "vertical interpolation: with/without extrapolation" option in Atmosphere > Ancillary > Start Dump. The default setting (with extrapolation) caused pathological data to appear, notably on Antarctica with temperatures below 100K… No wonder the model crashed. I am even surprised at how resistant it proved to be: some runs with nearly-0K temperatures on some regions of Antarctica succeeded!

Now I chose "without extrapolation". The interpolated data are much more credible, and I can totally cut orography with little problems.

I think you can close the ticket. Thanks for your help,

Jerome.

comment:5 Changed 11 years ago by willie

  • Resolution set to fixed
  • Status changed from accepted to closed
Note: See TracTickets for help on using tickets.