Opened 11 years ago

Closed 10 years ago

#358 closed help (fixed)

Setting environment variable NLSPATH

Reported by: anmcr Owned by: grenville
Component: UM Model Keywords: NLSPATH lib.cat
Cc: Platform:
UM Version: <select version>

Description

Hi,

I get the error message

'Unrecoverable library error
Unable to find error message (check NLSPATH, file lib.cat)'

I saw from a previous ticket that the solution was to copy lib.cat to my local directory and set the environment variable NLSPATH to point to it. I have done this bit still get the same error message. Could someone please help?

Job: xehwb
path: /home/n02/n02/anmcr/files/lib.cat

Thanks,

Andrew

Change History (7)

comment:1 Changed 11 years ago by grenville

  • Owner changed from um_support to grenville
  • Status changed from new to accepted

Andrew

I have looked at xehwb but can't see where NLSPATH has been set. Add NLSPATH to the list of environment varaibles in input/output control ans resources>Time convention and SCRIPT>. The other option would be to use the explain command at a Hector shell prompt. Here's some trace from man explain:

NAME

explain - PathScale? Fortran compiler and runtime error message explanation utility

SYNOPSIS

explain message_id

DESCRIPTION

The explain utility displays a detailed explanation for an error message printed by the PathScale?™ Fortran
compiler or runtime library.

When the Fortran compiler or runtime prints an error message, it prefixes the message with a string in the format
"subsystem-number", e.g. "pathf95-724". This is the message_id string that you must provide to the explain utility.

comment:2 Changed 11 years ago by anmcr

Dear Grenville,

Thanks for looking at this.

Could you please take another look at the job. I followed your instructions on how to add NLSPATH to the list of environment variables in the umui. However on re-running the job the error is still occurring. I would be grateful if you could check what I have done.

Thanks,

Andrew

comment:3 Changed 11 years ago by grenville

Andrew

NLSPATH should point to the file, so add /lib.cat to your entry - I'd move this file to /work rather than /home since the UM can't access /home when running. I hope that works.

Grenville

comment:4 Changed 11 years ago by anmcr

Dear Grenville,

Sorry to say but I am still getting the same error message. The steps I have taken are

1) Moved the file lib.cat to /home/n02/n02/anmcr/work
2) Set the Environment variable NLSPATH in 'Input/Output? Control and Resources'/'Script inserts and Modifications' to '/home/n02/n02/anmcr/work/lib.cat'. This was from a ticket from Ros.
3) Also set the NLSPATH in 'Input/Output? Control and Resources'/'Time convention and SCRIPT Environmental Variables', as you suggested.

Could you please have another look?

The job id is xehwb

Thanks,

Andrew (anmcr)

comment:5 Changed 11 years ago by grenville

Andrew

You have lib.cat in your home space. I think it needs to be in your work space - try putting it in /work/n02/n02/anmcr.

Grenville

comment:6 Changed 11 years ago by anmcr

Dear Grenville,

Your suggestion worked. I thought that /home/n02/n02/anmcr/work was the same as /work/n02/n02/anmcr, but obviously not.

Thanks for your help,

Andrew

comment:7 Changed 10 years ago by lois

  • Resolution set to fixed
  • Status changed from accepted to closed
Note: See TracTickets for help on using tickets.