Opened 10 years ago

Closed 10 years ago

#371 closed help (fixed)

Automatic job resubmission failed for xeoxb on MONSooN

Reported by: lherma Owned by: jeff
Component: MONSooN Keywords: MONSooN, resubmission, UM
Cc: simon Platform:
UM Version: 4.7

Description

From /home/lherma/umui_out/xeoxb000.xeoxb.d10014.t162207.leave:

llsubmit: Processed command file through Submit Filter: "/opt/ukmo/supported/libexec/filter.pl".
llsubmit: 2512-058 The command file "/scratch/jtmp/mon000.174061.0.lherma/umuisubmit_run.245840" does not

contain any "queue" keywords.

llsubmit: 2512-051 This job has not been submitted to LoadLeveler?.

Change History (7)

comment:1 Changed 10 years ago by jeff

  • Cc simon added
  • Owner changed from um_support to jeff
  • Status changed from new to accepted

Hi Leon

Between us Simon and I have hopefully sorted out this problem now. The umui on puma needed to be changed so you need to make sure you shut down any open jobs to pick up the changes. The job output file now goes to directory $HOME/output to be consistent with other UM versions. Give it a try and let me know if there are any problems.

Jeff.

comment:2 Changed 10 years ago by lherma

I tried running job xeqgc. Except for the job output file going to the directory 'output', everything else was the same including getting the same error and the job not resubmitting.

comment:3 Changed 10 years ago by jeff

You need to quit any jobs open before I changed the umui, reopen the jobs and click on process to pick up the umui changes.

Jeff.

comment:4 Changed 10 years ago by lherma

Hi Jeff

I'm not sure what you are saying. At the end of the day I always close down the UMUI and log out of PUMA. Could there still some change that has not been picked up?

One thing has changed - the .leave file goes to a directory called ~/output, so that means changes have been picked up, doesn't it?

The job is still not automatically resubmitting though.

Leon

comment:5 Changed 10 years ago by jeff

To pick up the umui changes you need to click on the process button to recreate the files in ~/umui_jobs/runid, have you done this.

The change to the output directory was done on the UM installation on monsoon, the changes to enable CRUN to resubmit was done to the umui on puma.

Jeff.

comment:6 Changed 10 years ago by lherma

Hi Jeff

The automatic resubmission seems to work now. I have managed to run the model for a full year. As you said, I had to re-process the job for it to pick up the relevant changes.

Hopefully, I should be able to run my ensembles now. Thank you!

Leon

comment:7 Changed 10 years ago by jeff

  • Resolution set to fixed
  • Status changed from accepted to closed
Note: See TracTickets for help on using tickets.