Opened 11 years ago

Closed 11 years ago

#429 closed help (fixed)

OUSRANCL (use of ocean single lev user ancil) Part 1

Reported by: agt Owned by: jeff
Component: UM Model Keywords: stash ocean user ancil
Cc: Platform:
UM Version: 4.5

Description

Dear all,

I would like to load in a new single level (surface) ocean field into um4.5 coupled, and then ultimately access the data therein to perturb surface radiation absorption. The first stage as I see it is to get it to load in correctly (and do nothing) but allow the model to run. Once that is done, then I'll look at actually using the data.

I have an ocean field that I have made intro an ancil using xancil. I have it on the correct grid, and land values are masked out- see /work/n02/n02/agt/ancil/oursancil I have set it up as section 0 and field 331 as described in the user guide. I've tried to make a userprestash record in: /export/puma/data-01/home/agt/umui_jobs/userprestash/chlorophyll_update

This at least seems to be successful in that I can now add the desired field (chlorphyll concentration) as an entry in the stash diagnostics list.

However, when trying to run the compiled job (using the reconfigured dump), it fails owing to,

"BUFFIN: Read Failed: Success

*
*
Model completed with the following :

Error Code : 2
Message : READDUMP: BAD BUFFIN OF DATA

*
*"

In this particular job (xeyjh), I have already tried raising the lookup headers for the ocean from 300 to 1000.

Please see /home/n02/n02/agt/um/umui_out/xeyjg000.xeyjg.d10138.t094745.leave and its comp companion for details

Any help is appreciated! Just to re-iterate, I am not trying to do anything with the data just yet, merely get it to load in (and update) successfully.

thanks,

Andy

Change History (3)

comment:1 Changed 11 years ago by jeff

  • Owner changed from um_support to jeff
  • Status changed from new to accepted

Hi Andy

The reason the UM crashes is the start dump doesn't actually contain the user ancillary field, it does have a pp header, which is why it shows up in xconv, but the actual data is missing. This means the problem is due to the reconfiguration. Looking at the code I can't see anything which would put the ocean user ancil in the dump, there is code to do this for the atmosphere but not the ocean! I think I have found a work around, in the umui panel

Ocean GCM → STASH → Initialisation of User Prognostics

Change the option value from 2 to 4, i.e. set the dump data to be missing data values. This should work okay because the field is updated from the ancillary file so its dump values are never used. Doing this enables the model to run, but obviously you need to check the values it gives for your user ancillary are correct.

Jeff.

comment:2 Changed 11 years ago by agt

Jeff,

thanks, that's a great workaround: the model integrates now, and in a test of 3 months output comparing D,J,F of the ancil input with monthly mean fields from the climate meaning/STASH, I have a good representation of the seasonal cycle of the new field (though not precisely the same, though I think that is to be expected),

cheers,

Andy

comment:3 Changed 11 years ago by jeff

  • Resolution set to fixed
  • Status changed from accepted to closed
Note: See TracTickets for help on using tickets.