Opened 10 years ago

Closed 10 years ago

#443 closed help (fixed)

problem submitting vn7.1 runs

Reported by: anmcr Owned by: willie
Component: PUMA Keywords: SSH
Cc: ros Platform:
UM Version: 7.1

Description

Hello,

I've having problems submitting vn7.1 jobs of the UM from PUMA. When I submit it hangs/stops at 'FCM_MAIN: Submitting'. Although the correct files seem to be copied to Hector, when I do qstat no job is running. Additionally mu umui 'hangs'. For example, see job xfbsa.

I have no idea what the problem is. I have submitted vn7.1 jobs in the past successfully such as the FCM tutorial job.

Thanks,

Andrew

Change History (8)

comment:1 Changed 10 years ago by willie

  • Owner changed from um_support to willie
  • Status changed from new to accepted

Hi Andrew,

I just submitted a 7.1 job, so it is working for me. I note that your .profile is using a UM 6.1 setup - you could change this to 7.,1 and try again.

Regards,

Willie

comment:2 Changed 10 years ago by ros

  • Cc ros added
  • Component changed from UMUI to PUMA
  • Keywords SSH added

Hi Andrew,

The output in your

$HOME/um/um_extracts/xfbsa/umbase/ext.out file indicates that there is a problem logging in to HECToR.

Permission denied (publickey,keyboard-interactive).

You must have passwordless ssh set up and working to submit FCM UM jobs.

If you run the following on PUMA are you logged into HECToR without the need to enter a password?

ssh <userid>@login.hector.ac.uk

If not then you need to set this up or fix it by following the instructions here: http://puma.nerc.ac.uk/trac/UM_TUTORIAL/wiki/Ros/sshAgent

Since you said you have previously submitted a vn7.x job, it may be as simple as re-doing step 2 (copying your public key across to HECToR). Somehow your keys may have got messed up.

Regards,
Ros

comment:3 Changed 10 years ago by anmcr

Dear Willie and Ros,

Thanks for this.

I'm afraid that I done something stupid with 'vi' while trying to edit my .profile on hector. Can I copy someone's .profile over to my directory?

Sorry,

Andrew

comment:4 Changed 10 years ago by ros

Feel free to take a copy of mine if you want. But you will probably wish to delete the 'alias' lines and those exporting the PATH environment variable. Maybe take a look at Willie's too and see which suits you better - he may have less 'junk' in his!

comment:5 Changed 10 years ago by anmcr

Dear Willie and Ros,

I took Ros's .profile and re-did the passwordless ssh, and my job was submitted ok.

A small question is that in Ros's .profile the version of the UM was set to 7.4, as I am submitting a 7.1 job do I need to change this to 7.1, or if I am submitting a 6.1 job then change to 6.1?

Thanks for your help,

Andrew

comment:6 Changed 10 years ago by ros

Hi Andrew.

For simplicity it is advised to set the UM version in your .profile to be the same as the jobs you are submitting.

However if you are running jobs of differing UM versions at the same time… For jobs prior to vn7.x you do need to make sure the UM version is set correctly in your .profile.

At version 7.x onwards it is not necessary as the UM scripts source the correct version of the umsetvars file automatically. You just need to be careful if you use any of the UM utilites (eg. cumf, pumf, convpp) as you'll pick up those associated with the UM version you have set in your .profile.

Hope that helps.
Cheers,
Ros.

comment:7 Changed 10 years ago by anmcr

Thanks Ros.

Please close this ticket.

Andrew

comment:8 Changed 10 years ago by ros

  • Resolution set to fixed
  • Status changed from accepted to closed
Note: See TracTickets for help on using tickets.