Opened 10 years ago

Closed 9 years ago

#448 closed help (fixed)

Difference between two runs, one with an additional field in STASH

Reported by: aschurer Owned by: lois
Component: UM Model Keywords:
Cc: Platform:
UM Version: 4.5

Description

Hi.
Midway through a long run I decided I wanted an additional daily output - the daily mean 1.5m temperature. Consequently I stopped the run added the desired field to the STASH files and started the run from a reconfigured previous dump file, using the already existing exec file from the first run.

There was a slight overlap between the two runs in order to test that the second run started OK. A comparison between the first and second runs however revealed slight differences between the two runs, which worried me slightly.

I started another run identical to the second run expect this time I did not reconfigure the dump files. This run was identical to the second run and was therefore still not the same as the first run.

As a sanity check I removed the additional file from the STASH and ran the model again. The output was identical to the first run.

Hence I surmised that the additional daily output field added to the STASH must be causing the slight perturbation in the model run.
Could this be correct? And if so could you possibly explain to me what is causing this perturbation.

Thanks,
Andrew

Change History (4)

comment:1 Changed 10 years ago by lois

  • Owner changed from um_support to lois
  • Status changed from new to assigned

Hello Andrew,

sorry for the delay in replying. Are you running your experiment on the local system as we have never had a problem reported to us on HECToR?

You are right if you reconfigure in the middle of a run then there are slight differences before and after reconfiguration but you should not get slight differences between 2 runs without reconfiguration and certainly adding a new STASH should not cause any differences. There are a few 'troublesome' STASH items that have caused differences.

Can you tell me how you assess the difference are you looking at dumps your your STASH field? Do you have climate meaning turned on?

Thanks

Lois

comment:2 Changed 10 years ago by aschurer

Hello Lois,

Yes I am running the simulation on HECToR and I do have climate meaning turned on. (The experiments in question are xfam#b and #c)

I checked the differences by producing plots of mean monthly surface temperature against time. While the two experiments with a different STASH code looked identical over several years the original experiment showed clear discrepencies.

For the run with a reconfigured dump file I compared the sea level pressure field of the original dump file with the sea level pressure field found in xfamb.astart and found that they were identical.I therefore assumed that the reconfiguration was not actually changing the dump file.

I hope this answers your questions.

Thanks,
Andrew

comment:3 Changed 10 years ago by lois

Thanks for the information Andrew, we will have a look and see what might be the cause of this curious problem.

Lois

comment:4 Changed 9 years ago by ros

  • Resolution set to fixed
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.