Opened 10 years ago

Closed 10 years ago

#450 closed help (fixed)

reconfiguration build: failed

Reported by: anmcr Owned by: ros
Component: UM Model Keywords: fcm.bld.lock
Cc: Platform:
UM Version: 7.1

Description (last modified by ros)

Hello,

I took a vn7.1 job from 'umui' and tried to run it. I get an error that the reconfiguration fails to build. See below. I searched for this error in other tickets but couldn't see anything like it. The job id is xfbsa

Thank you,

Andrew

Build command finished on Mon Jul 12 14:03:56 2010.
Model build: OK
ERROR: /work/n02/n02/anmcr/xfbsa/umrecon/fcm.bld.lock: lock file exists,
       /work/n02/n02/anmcr/xfbsa/umrecon: destination is busy.
Build failed on Mon Jul 12 14:04:03 2010.
Build command started on Mon Jul 12 14:03:57 2010.
->Parse configuration: start
Config file (bld): /work/n02/n02/anmcr/xfbsa/umrecon/cfg/bld.cfg
Config file (bld): /work/n02/n02/anmcr/xfbsa/umbase/cfg/bld.cfg
->Parse configuration: 6 seconds
->Setup destination: start
Destination: anmcr@nid00008:/work/n02/n02/anmcr/xfbsa/umrecon
Rename existing bld cfg: /work/n02/n02/anmcr/xfbsa/umrecon/cfg/20100621_162731_parsed_bld.cfg
Generated bld cfg: /work/n02/n02/anmcr/xfbsa/umrecon/cfg/parsed_bld.cfg
->Setup destination: 0 second
->TOTAL: 6 seconds
Reconfiguration build: failed
--------------------------------------------------------------------------------

Resources requested: cput=01:00:00,mpparch=XT,mpphost=none,mppnppn=1,mppwidth=0,ncpus=1,place=pack
Resources allocated: cpupercent=137,cput=00:28:16,mem=602240kb,ncpus=1,vmem=801868kb,walltime=01:22:44

*** anmcr   Job: 733298.sdb   ends: 12/07/10 14:04:03   queue: serial_1h ***
*** anmcr   Job: 733298.sdb   ends: 12/07/10 14:04:03   queue: serial_1h ***
*** anmcr   Job: 733298.sdb   ends: 12/07/10 14:04:03   queue: serial_1h ***
*** anmcr   Job: 733298.sdb   ends: 12/07/10 14:04:03   queue: serial_1h ***

Change History (5)

comment:1 Changed 10 years ago by ros

  • Keywords fcm.bld.lock added; reconfiguration removed
  • Owner changed from um_support to ros
  • Status changed from new to accepted

Hi Andrew,

The key to the problem is in the error message:

Build command finished on Mon Jul 12 14:03:56 2010. 
Model build: OK 
ERROR: /work/n02/n02/anmcr/xfbsa/umrecon/fcm.bld.lock: lock file exists,
    /work/n02/n02/anmcr/xfbsa/umrecon: destination is busy.

The fcm.bld.lock file is created to ensure that the job is not submitted to compile multiple times concurrently. However, if the compile job is interrupted for some reason - e.g. job ran out of queue time or was killed by the user the fcm.bld.lock file is left behind and has to be manually deleted.

Assuming that you didn't inadvertantly submit the job multiple times you need to delete /work/n02/n02/anmcr/xfbsa/umrecon/fcm.bld.lock and retry.

Regards,
Ros.

comment:2 Changed 10 years ago by anmcr

Dear Ros,

I done as you suggested and the run progressed slightly further but still failed when building the reconfiguration. The output from the .comp file is below. I saw a previous ticket on the 'No rule to make target' and looked at the advice on http://puma.nerc.ac.uk/trac/UM/wiki/FrequentlyAskedQuestions#gmake-no-rule-to-make-target. However, I couldn't find the 'f90_unix_io.f90' file in the directory /home/n02/n02/anmcr/work/xfbsa/umrecon??. Are you able to help?

The job is xfbsa, which is a global job. What is surprising is that I got the original 'umui' version to run without any difficulty - this is job xelhb. xfbsa is a only slightly modified version of this (date, STASH, .ice and .sst ancillaries reconfigured).

Thanks,

Andrew

gmake: * No rule to make target f90_unix_io.o', needed by um_fort_flush.o'. Stop.
gmake:
* Waiting for unfinished jobs….
gmake: * Waiting for unfinished jobs….
# Time taken: 1 s⇒ gmake -f /work/n02/n02/anmcr/xfbsa/umrecon/Makefile -j 6 -s all
gmake -f /work/n02/n02/anmcr/xfbsa/umrecon/Makefile -j 6 -s all failed (2) at /work/n02/n02/hum/fcm/bin/../lib/Fcm/Build.pm line 597
cd /nfs01/n02/n02/anmcr
Build failed on Mon Jul 12 16:45:22 2010.
→Make: 1 second
→TOTAL: 701 seconds
Reconfiguration build: failed

comment:3 Changed 10 years ago by ros

  • Description modified (diff)

Hi Andrew,

I think it's just got itself rather confused, I don't think there are any changes to your job that should cause a problem. I've just taken a copy of your job and successfully compiled the reconfiguration.

I suggest you remove the /work/n02/n02/anmcr/xfbsa/umrecon directory on HECToR and retry, that should hopefully be enough to get a clean build of the recon exec.

Ros.

comment:4 Changed 10 years ago by anmcr

Dear Ros,

I did as you suggested and the run completed successfully.

Thanks for your help.

Andrew

comment:5 Changed 10 years ago by ros

  • Resolution set to fixed
  • Status changed from accepted to closed

Thanks for letting us know. I'll go ahead and close this ticket now.

Note: See TracTickets for help on using tickets.