Opened 10 years ago

Closed 10 years ago

#452 closed help (fixed)

reconfiguration/ancillary problem

Reported by: anmcr Owned by: willie
Component: UM Model Keywords: reconfiguration
Cc: Platform:
UM Version: 7.1

Description

Hello,

I have a job 'xfbsb' which gives the error 'INANCILA: Wrong calender set in ancillary file'. See below. I made the .sst, .ice, .orog, and .lsm ancillaries which the model uses myself, however the .sst and .ice were set with 'gregorian' calender which is consistent with the 365 day calender which I believe the model uses.

There was one previous ticket with this failure, but I still wasn't able to solve the problem myself.

thanks,

Andrew

*
ERROR!!! in reconfiguration in routine Rcf_Ancil_Atmos
Error Code:- 110
Error Message:- INANCILA : Wrong calendar set in Ancillary File
Error generated from processor 0
*

aborting job:
application called MPI_Abort(MPI_COMM_WORLD, 9) - process 0
[NID 12762] 2010-07-13 16:44:18 Apid 2068086: initiated application termination
/work/n02/n02/anmcr/xfbsb/bin/qsexecute: Error in dump reconfiguration - see OUTPUT


Change History (7)

comment:1 Changed 10 years ago by jeff

  • Owner changed from um_support to jeff
  • Status changed from new to accepted

Hi Andrew

The UM is complaining about file

/work/n02/n02/anmcr/UMAncil/CLIM/Antarctica12km/new_qrparm.orog

This has a 360 day calendar but your run is for a Gregorian calendar. Similarly for your mask file. Even though these files are not time varying the UM still complains if the calendar is wrong.

Jeff.

comment:2 Changed 10 years ago by anmcr

Dear Jeff,

I changed the ancillaries and run worked.

However, now I'm continually getting the 'RHS set to zero, failed to converge' error with very unrealistic vertical velocities. I thought that it might have been due to the ancillaries I created, so I ran with the standard climatological ancillaries for .orog, .mask, .sst, and .ice - but it still failed to converge. I then switched off all ancillaries so it was only using the N320 startdump — but this also failed to converge.

I'm very puzzled by all this as the job is a almost straight copy from the vn7.1 'NAE run' except I have moved it to cover all of Antarctica and the surrounding Southern Ocean. This run worked fine using vn6.1 of the model.

Could you please take a look. The only thing I have not tried is to decrease the timestep — but I wouldn't have thought that that would have been necessary for such a straight forward use of the model.

Thanks,

Andrew

comment:3 Changed 10 years ago by jeff

  • Owner changed from jeff to willie
  • Status changed from accepted to assigned

Hi Andrew

I'm away for the next 2 weeks so I'll reassign this query to Willie, hopefully he will be able to help you.

Jeff.

comment:4 Changed 10 years ago by willie

  • Keywords reconfiguration added

Hi Andrew,

Something has gone wrong with the reconfiguration. The field "surface temperature after time step" has been overwritten by the previous field "snow amount over land". I am not sure why this has happened. If you have a start dump reconfigured by UM6.1 this might be worth looking at.

Regards,

Willie

comment:5 Changed 10 years ago by anmcr

Dear Willie,

Thanks for looking at this.

Do you think the problem is with the start dump or the job? I've tried running with a new vn6.1 and vn7.1 startdump but with no success.

Also, when you spotted that the surface temperature after timestep field was being overwritten in the reconfiguration, was that from exaiming the .leave file or through exaiming the reconfigured startdump fields individually.

Best wishes,

Andrew

comment:6 Changed 10 years ago by anmcr

Dear Willie,

I copied another 7.1 job and the run now works fine.

I've no idea what the problem was.

But please close this ticket.

Thanks,

Andrew

comment:7 Changed 10 years ago by willie

  • Resolution set to fixed
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.