Opened 10 years ago

Closed 10 years ago

#453 closed help (fixed)

problems with mods

Reported by: jcrook Owned by: lois
Component: UM Model Keywords:
Cc: Platform:
UM Version: 4.5

Description

I am trying to write a modification to the radiation code to use data from my ancillary files. I have accessed information about the UM4.5 code through the NCAS-CMS web site but when I include my mods in my job and compile, it complains that the identifier is unknown and modification is not declared, eg.

  1. *DECLARE ATM_PHYS

* UKNOWN IDENTIFIER

  1. *D ATMPHY1.209

* MODIFICATION NOT DECLARED

my mod is at /home/n02/n02/jcrook/work/um/mods/fixed_cloud
I also have one called ancil_land there and I'm not sure if thats ok either. The output from the compilation is at /home/n02/n02/jcrook/um/umui_out/xesaf00*.d10196.t163*.comp.leave

Change History (3)

comment:1 Changed 10 years ago by lois

  • Owner changed from um_support to lois
  • Status changed from new to assigned

Hello Julia,

the permissions on your files on HECToR are not set so that people in the NCAS group can read them. If you want to change this so I see your files you need to use the command

chmod g+rx <file>

for all the directories en route to where your file is as well as for the file itself.

Without seeing your mod I think that the problem is that you are decalring the subroutine name not the nupdate deck name which contains the subroutine. So for the subroutine ATM_PHYS this is in the nupdate deck called ATMPHYS1. You can test your mod by changing the name you use in the declare statement. Try to run this again and see how far it gets now.

If you change your file permissions it will be easier to help you if things are still not right.

Lois

comment:2 Changed 10 years ago by jcrook

I've used the decknames now and its ok. Thanks.

comment:3 Changed 10 years ago by lois

  • Resolution set to fixed
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.