Opened 10 years ago

Closed 8 years ago

#459 closed help (fixed)

problem with um 4.5.1 (HadAM3) reconfiguration

Reported by: sjh395 Owned by: lois
Component: UM Model Keywords:
Cc: Platform:
UM Version: 4.5

Description

My experiment tcyqb is nearly identical to another experiment of mine which reconfigures and runs OK (there are changes to the atmospheric composition and ancillary files, no changes to mods). When doing the reconfiguration step it has compiled ok but then fails when trying to reconfigure with the following error:

/work/n02/n02/sjh395/um/tcyqb/tmp/modscr_tcyqb/qsprelim: line 741: 31642: Bus error
/work/n02/n02/sjh395/um/tcyqb/tmp/modscr_tcyqb/qsprelim: Error in dump reconfiguration - see OUTPUT

The rest of the leave file doesn't give me many clues.

I did use xancil to create my qrclim.sst and qrclim.ice ancillaries from netcdfs, on inspection these look OK. Could a problem with these (in the original netcdfs) cause the error message?

Thanks in advance

Stephen Hunter

Change History (3)

comment:1 Changed 10 years ago by lois

  • Owner changed from um_support to lois
  • Status changed from new to assigned

Without looking more closely Stephen it could be that you have just run out of memory for the reconfiguration. At vn 4.5 reconfiguration is a serial task and so we have had memory problems before. The simplest way to get round this, if it is memory, is to run reconfiguration for some ancillary files and then run it again for the other ancillary files. Is this possible?

Lois

comment:2 Changed 10 years ago by sjh395

As you suggested, I tried changing many of the fields so that they werent reconfigured, but the same error message arose. Its strange because the experiment I copied it from reconfigures OK (although using different ancilliary files). I am trying to reconfigure an instantenous dump file from the working experiment for this new experiment.

/work/n02/n02/sjh395/um/tcyqb/tmp/modscr_tcyqb/qsprelim: line 741: 7174: Bus error

where L741 within script qsprelim is " $LOADRECON <$RECONCTLA >>$OUTPUT "

Is this "Bus error" reported by the reconfig program?

Its a HadAM3 run, I am making significant changes to all the fields (including land-sea mask), does the reconfiguration have particular difficulties with this?

Thanks Stephen

Kind regards

Stephen

comment:3 Changed 8 years ago by ros

  • Resolution set to fixed
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.