Opened 9 years ago

Closed 9 years ago

#497 closed help (fixed)

problem with 'fcm commit'

Reported by: anmcr Owned by: ros
Component: FCM Keywords:
Cc: Platform:
UM Version: 7.1

Description

Hi,

I want to increase the value of orog_blend_max in

utility/qxreconf/rcf_readnl_horizont_mod.F90 to 40.

I created a branch and modified the code But I had problems when I tried to check out using 'fcm commit'. See error message below which occured immediately after I closed the 'commit message'. I therefore couldn't enter 'y' to properly commit the branch.

Thanks,

Andrew

anmcr@puma:/home/anmcr/um_work/VN7.1_increased_blendingzone_maxsize> fcm commit               
Starting nedit to edit commit message ...
Change summary:
--------------------------------------------------------------------------------                                                                     
[Project: UM]
[Branch : branches/dev/anmcr/VN7.1_increased_blendingzone_maxsize]
[Sub-dir: <top>]

M      src/utility/qxreconf/rcf_readnl_horizont_mod.F90
--------------------------------------------------------------------------------
Commit message is as follows:
--------------------------------------------------------------------------------
orog_blend_max changed to 40


--------------------------------------------------------------------------------
Would you like to commit this change?
Enter "y" or "n" (or just press <return> for "n"): Use of uninitialized value $answer in scalar chomp at /home/um/fcm/bin/../lib/Fcm/Interactive/InputGetter/CLI.pm line 34.
[ABORT] commit: abort by user.

Change History (5)

comment:1 Changed 9 years ago by ros

  • Status changed from new to accepted

Hi Andrew.

Did you try running "fcm commit" a second time? If not can you please try it again. I just ran the command in your VN7.1_increased_blendingzone_maxsize directory and it did allow me to enter "n" (or "y" if I had permission) after closing the commit message. FCM may just have got itself a little confused.

Let me know if you still have problems.

Regards
Ros.

comment:2 Changed 9 years ago by anmcr

Hi Ros,

Thanks for looking at this.

I tried again and it gave the same problem.

Andrew

comment:3 Changed 9 years ago by ros

Ok. I can't repeat the problem so I think the easiest solution, since it is only a one line change, is to

  1. Delete your /home/anmcr/um_work/VN7.1_increased_blendingzone_maxsize directory.
  1. Run "fcm co fcm:um_br/dev/anmcr/VN7.1_increased_blendingzone_maxsize" to checkout your branch.
  1. Edit rcf_readnl_horizont_mod.F90 to modify orog_blend_max
  1. cd to /home/anmcr/um_work/VN7.1_increased_blendingzone_maxsize and run "fcm commit" afresh.

comment:4 Changed 9 years ago by anmcr

Thanks Ros,

This worked. Please close the ticket.

Andrew

comment:5 Changed 9 years ago by ros

  • Resolution set to fixed
  • Status changed from accepted to closed
Note: See TracTickets for help on using tickets.