Opened 9 years ago

Closed 9 years ago

#507 closed help (fixed)

problem with reconfiguration?

Reported by: anmcr Owned by: willie
Component: UM Mesoscale Keywords: reconfiguration, 1km
Cc: Platform:
UM Version: 7.1

Description

Hello,

I have trying to run a 1km job over a region of Antarctica. The reconfigured startdump from this run and dumps from the first few timesteps all show very odd values in fields such as surface temperature. I think there is therefore a problem with the reconfiguration.

The 1 km job is 'xfbsy'. I outputed dumps for the first 5 or so timesteps.

The 'parent' 4 km job is 'xfbsj' and the dump is 'xfbsja_da001' is the one which is used to initiate the 1 km run.

Thanks for any help.

Andrew

Change History (7)

comment:1 Changed 9 years ago by willie

Hi Andrew,

The surface temperature field is completely wrong and appears folded at 197.81 deg longitude. The values are zero and 50,000 which looks like snow amount. Is this a repeat of ticket #452? Since this is the only field that is wrong, it may be worth repeating the run.

Regards,

Willie

comment:2 Changed 9 years ago by anmcr

Dear Willie,

It wasn't meant to be a repeat of ticket #452, as that was a 12km run using vn7.1. However, the problem seems very similar in that it was to do with the surface temperature field being overwitten by the smow amount field. I never found out what was wrong with that job as I tried a different basis file and the problem simply never occured.

I re-ran the job a number of times using different configurations of ancillary files before raising the ticket, and got the same problem each time (job xfbsw).

I solved the problem last time by simply using a new 12km basis file. Could you recommend a 1km vn7.1 basis file which you know to be working?

Thanks,

Andrew

comment:3 Changed 9 years ago by anmcr

Dear Willie,

Sorry, but I did accidently delete xfbsj.

I have 2 other 1 km runs which fail with the same problem.

xfbsw: .mask and .orog ancillaries are not used (actually no ancillaries are used)
xfbsy: .mask and .orog 1km ancillaries are used (this is a copy of xfbsj)

Thanks,

Andrew

comment:4 Changed 9 years ago by willie

  • Owner changed from um_support to willie
  • Status changed from new to accepted

HI Andrew,

I have not made much progress with this. I have now emailed the Met Office gurus for further help.

I notice that in your global run xfbsa, you are overwriting the input start dump with the reconfigured start dump (because DATAW= $DATADIR/$RUNID). There is the possibility of overwriting fields that you haven't yet read: it depends on how the reconfiguration code works. If it reads the entire dump in one go, then you are safe; if it reads individual fields as necessary, there could be trouble.

I also notice that in the Antarctic LAM xfbsf.astart, there is a longitudinal ridge of high surface temperature that looks artificial.

I will let you know of any further developments.

Regards,

Willie

comment:5 Changed 9 years ago by willie

Hi Andrew,

Paul Selwood at the Met Office has confirmed that the reconfiguration reads and writes individual fields, so you probably need to start the processing chain again. Sorry.

Regards,

Willie

comment:6 Changed 9 years ago by anmcr

Thanks Willie,

I'II re-run the model sequence starting from the global model, and keep an eye on whether I'm overwriting.

I'II let you know next week how I get on.

Andrew

comment:7 Changed 9 years ago by willie

  • Resolution set to fixed
  • Status changed from accepted to closed
Note: See TracTickets for help on using tickets.