Opened 13 years ago

Closed 13 years ago

#51 closed help (fixed)

XCONV: Converting file to Grads

Reported by: caroline@… Owned by: jeff
Component: UM Model Keywords:
Cc: Platform:
UM Version:

Description

Hi NCAS,

I am with converting a single parameter in start file xaexc.astart, into grads with xconv both at Leeds and at hpcx. The data is there when I 'view data' on the original file, but when I convert it to grads or netcdf, the new file is full of 0's or 2.0000e+20

Also when I plot any of the parameters in the original .astart file, the program breaks and causes a segmentation fault.

When I sftp'd the .astart to Leeds to try to do the conversion here, it appears to have wiped all the information from the file (when I view the data there is nothing), so I can't do the conversion here.

Any advice on what to do/try? The file in question is at /hpcx/devt/n02/n02-ncas/cbain/xaexc/xaexc.astart

Thanks,
Caroline

Change History (5)

comment:1 Changed 13 years ago by jeff

  • Owner changed from um_support to jeff
  • Status changed from new to assigned

Hi Caroline

The problem is your file doesn't have any data in it! All the pp headers are there which is what xconv reads when you load the file, but when you try to convert something there is no data.

Jeff.

comment:2 Changed 13 years ago by umdoc

Hi Jeff,

Thanks, funny that there is something in the view data bit, but I think you're right - I just checked the .leave file for that job and it doesn't seem to find the ancillary files I'm pointing it too (/hpcx/home/n02/n02/umx/vn6.1/ancil/atmos/n320) even though they are all there and complete.

It's the same job you helped me with in ticket #38 so I think you already have the basis file(?). So it ran better than last time, but it's still not working.

Thanks for the help,
Caroline

comment:3 Changed 13 years ago by jeff

The problem is in soil parameters ancillary file umui window you give the pathname as $UM_ANCIL_GLll/qrparm.soil_sahara, but UM_ANCIL_GLll doesn't exist. All other ancils use UM_ANCIL_GL.

Jeff.

comment:4 Changed 13 years ago by umdoc

Great, thanks, all working now, including the xconv problem, you can close this, thanks for the help.

Best Wishes,

Caroline

comment:5 Changed 13 years ago by jeff

  • Resolution set to fixed
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.