Opened 9 years ago

Closed 9 years ago

#511 closed help (fixed)

Header error in soil moisture ancillary file

Reported by: cbirch Owned by: willie
Component: UM Model Keywords: ancillary, header, LNER
Cc: Platform:
UM Version: 7.1

Description

Hi,

I have modified the soil moisture ancillary file (/home/n02/n02/cbirch/work/ancils/AMMA/soil_moisture/qrclim_SMobs64.smow) by converting the original to netcdf in xconv, editing the values in matlab, saving back to netcdf and then converting back in xancil. I keep getting this error when I try to run the job (xfjha):

Inconsistency in Real Headers.
Real Header Values.

1 Anc File 0.110015869140625 Model Dump 0.11
2 Anc File 0.1100006103515625 Model Dump 0.11
3 Anc File -15. Model Dump -15.
4 Anc File 335. Model Dump 335.
5 Anc File 79. Model Dump 79.
6 Anc File 180. Model Dump 180.

Error in INANCILA
CMESSAGE INANCILA: REAL header Error.
ErrorStatus? 8

*
ERROR!!! in reconfiguration in routine Rcf_Ancil_Atmos
Error Code:- 8
Error Message:- INANCILA: REAL header Error.
Error generated from processor 0
*

I read on a previous ticket that this is due to rounding errors and could be solved by using a 64 bit netcdf when converting from the original pp file in xconv. I tried this but got the same error.

Any idea how to fix this? I guess it is the first and second header values that are the problem. I'm not sure what these represent.

Cheers,
Cathryn

Change History (3)

comment:1 Changed 9 years ago by willie

  • Keywords header, LNER added; header removed
  • Owner changed from um_support to willie
  • Status changed from new to accepted

Hi Cathryn,

If you look at your smow ancillary file in xconv and click the Trans button (top right) you will see that your row and column spacing are slightly inaccurate. This is causing the UM to fail the "LNER" test, which checks that |x-y| > 10-6 |x+y| where x is from your ancillary and y is from the model dump. It looks like in all the modifications to the ancillary file, a numerical error has crept in. Is it possible to re-create the ancillary file?

Regards,

Willie

comment:2 Changed 9 years ago by cbirch

Hi Willie,

Thank you for pointing out what the headers relate to and where to view them. I re-created the ancillary file in exactly the same way and checked the headers and they were fine this time. Not sure why this should be so but the job ran fine anyway.

Thanks a lot for your help. You can close this ticket now.

Cathryn

comment:3 Changed 9 years ago by willie

  • Resolution set to fixed
  • Status changed from accepted to closed
Note: See TracTickets for help on using tickets.