Opened 10 years ago

Closed 10 years ago

#533 closed help (fixed)

Using an ancillary file that updates hourly

Reported by: cbirch Owned by: jeff
Component: UM Model Keywords:
Cc: Platform:
UM Version: <select version>

Description

Hi,

I am trying to run a LAM job over West Africa with hourly updated soil moisture (xfjha).

I get this error:

UM ERROR (Model aborting) :
Routine generating error: UP_ANCIL
Error code: 636
Error message:

REPLANCA: Non-standard period for periodic data

The ancillary file I created is here:/home/n02/n02/cbirch/work/ancils/AMMA/soil_moisture/qrclim_SMobs_hourly2.smow.

As far as I know the time dimension is correct, although I am not completely sure because I cannot find any documentation which states what the standard period should be or an example of an ancillary file containing hourly data.

Thanks for your help,
Cathryn

Change History (4)

comment:1 Changed 10 years ago by lois

Hello Cathryn,

this problem can be due to a number of things, a mismatch of calendars, settings in the UMUI and your file, even hard coded restrictions in the updating routine. It can take time to investigate however the people who are knowledgable in this area are out of the office Monday and Tuesday and so this investigation will not get underway until Wednesday.

Lois

comment:2 Changed 10 years ago by jeff

  • Owner changed from um_support to jeff
  • Status changed from new to accepted

Hi Cathryn

I think the problem is because you have created these ancillary files as being periodic, i.e. they will repeat themselves every 48 hours. Is this what you meant to do? You cannot have data with an interval of 1 hour and a period of 2 days in the UM, although it would allow a period of 1 day. If you don't need the data to be periodic recreate the ancillary files with this turned off and then I think it should all work okay.

Jeff.

comment:3 Changed 10 years ago by cbirch

Hi Jeff,

I misunderstood what' periodic' meant. I thought it meant an ancillary file that simply contained multiple times at regular intervals. I switched this off in xancil and the job seems to run fine now.

Thanks a lot,
Cathryn

comment:4 Changed 10 years ago by jeff

  • Resolution set to fixed
  • Status changed from accepted to closed
Note: See TracTickets for help on using tickets.