Opened 10 years ago

Closed 10 years ago

#542 closed help (fixed)

HadGEM3 run on MONSOON

Reported by: PUMA_GarryHayman Owned by: um_support
Component: UM Model Keywords: HadGEM3, MONSooN
Cc: Platform:
UM Version: 7.3

Description

Ros,

I recently started an experiment (xfbfh) on MONSOON to simulate a 15-year period from 1999. The model run successfully for 5 years and then crashed. Colleagues at CEH have been unable to assist and suggested I contact you.

I have extracted the following from the leave and processor files:

·         /home/ghayma/output/xfbfh015.xfbfh.d10311.t173735.leave – has the following error message

 OPEN:  File Open Failed: A file or directory in the path name does not exist.

 gc_abort (Processor  2 ): TRANSIN: I/O read error

·         /projects/jules/ghayma/xfbfh/xfbfh.fort6.pe2

 MEANCTL: ***** Called in ATMOSPHERIC mode *****
 MEANCTL: Period_ 1  mean dump to be created this timestep
 MEANCTL: Period_ 2  mean dump to be created this timestep
 Period_1 data read from unit number  24
 Period_1 data written to unit number  23
 OPEN:  File /scratch/ghayma/xfbfh/xfbfh.aotrans.0002 to be Opened on Unit 17 does not Exist
OPEN:  File /scratch/ghayma/xfbfh/xfbfh.aotrans.0002 Created on Unit 17
OPEN:  Claimed 32000512 Bytes (4000064 Words) for Buffering
OPEN:  Buffer Address is                   1FE67F30
CLOSE: File /scratch/ghayma/xfbfh/xfbfh.aotrans.0002 Closed on Unit 17
 TRANSOUT: Length transferred= 4910755
 ACUMPS: Error reading header: IO code  0.000000000000000000E+00  on unit  24
 Words requested  2048  Words read  0
 MEANCTL: RESTART AT PERIOD_ 0
 DELHIST: failure to delete history file
 U_MODEL: interim history file deleted due to failu     re writing partial sum files
 *********************************************************************************

 UM ERROR (Model aborting) :
 Routine generating error: U_MODEL
 Error code:  1
 Error message:
ACUMPS: BUFFIN error - see output
 *********************************************************************************

The output is in /projects/jules/ghayma/xfbfh.

Do you have any ideas as to the cause of the crash? Do you think that there are any quota issues? The code was writing to /scratch/ghayma/xfbfh. This has now been cleared. Is there a time limit on it?

I have another question. Are there any hand edits needed for the interactive wetland CH4 scheme? The reason I ask is that experiment (xfbff) for a 2-month simulation was giving very high CH4 concentrations, which I think is caused by a mismatch in units of the CH4 wetland emissions. The interactive wetland CH4 emissions appear to be in units of micrograms C m2 s-1 whereas the UKCA Is expecting the emissions to be in kg C m-2 s-1. There is a factor of 1.00E+09 in the routine ch4_wetl.F90 (in the directory: /home/PUMA_GarryHayman/VN7.3_CH4_WETLANDS/src/atmosphere/land_surface)

Any assistance that you can give would be gratefully received.

I look forward to hearing from you.

Regards

Garry


Change History (2)

comment:1 Changed 10 years ago by ros

[copied from email]

Hi Garry,

Files in /scratch are deleted after 4 days. The only files that should be written to the /scratch file space are ones that the currently running job will use. Any files that are used for resubmission and restarting a run; scripts, dumps and history files, etc are placed in your /projects or /home space.

As far as I can see the Jules project still has plenty of disk space available.

I'm going to copy your query into the UM Helpdesk in case anyone else in my team recognise the symptoms.

Regarding the problem with the wetland CH4 scheme, I am unaware of any patches or hand-edits that are needed. I will ask a couple of colleagues here in case they know of anything, otherwise I suggest talking to people at the Met Office. Could Nic Gedney point you in the direction of who would be best to ask?

Regards,
Ros.

comment:2 Changed 10 years ago by ros

  • Resolution set to fixed
  • Status changed from new to closed

Garry managed to get his run restarted after correcting a mismatch between the start date and the date in the start dump.

Note: See TracTickets for help on using tickets.